summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/gimp-help')
-rw-r--r--app-doc/gimp-help/Manifest2
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.34-r2.ebuild81
-rw-r--r--app-doc/gimp-help/gimp-help-2.8.2.ebuild31
-rw-r--r--app-doc/gimp-help/metadata.xml11
4 files changed, 91 insertions, 34 deletions
diff --git a/app-doc/gimp-help/Manifest b/app-doc/gimp-help/Manifest
index e7275cf1c9fc..f364e53f8979 100644
--- a/app-doc/gimp-help/Manifest
+++ b/app-doc/gimp-help/Manifest
@@ -1 +1 @@
-DIST gimp-help-2.8.2.tar.bz2 158504580 BLAKE2B d0023a4290879f97e3365f1208427997d1facc09a7ed4ac0a274615e9eff378c9a4da0d7c5190bc24ad27c2b03d6c513003297d835562b0fa3e02685443d15e9 SHA512 3afdaa8b2f005d939d039d2e22c8306145e7b7acaca5ef89279998e87931e99d1fe607f1337f7796d667d5c6be456ba976b3c8a937c9dd6b1888d7158cfbed67
+DIST gimp-help-2.10.34.tar.bz2 165540436 BLAKE2B eff5afe87bbddf9166647424ef63399a4ebc4215980dddf42f949e18245c60d1095269592f5a314683f7e1d7b27e2b9130215bda5987e7c8dfcafb5cebb6abbc SHA512 316d558f66c96a0d2d0f17baf700020b76aa221f9e220ddfc3e85b10c82b20b9c1cf36893776a342e90af5170e0102eb743b79663451581444d4f881256cf377
diff --git a/app-doc/gimp-help/gimp-help-2.10.34-r2.ebuild b/app-doc/gimp-help/gimp-help-2.10.34-r2.ebuild
new file mode 100644
index 000000000000..496d138224d0
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.10.34-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="https://docs.gimp.org/"
+SRC_URI="mirror://gimp/help/${P}.tar.bz2"
+
+LICENSE="FDL-1.2+"
+SLOT="2"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+IUSE="nls"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
+ app-text/docbook-xml-dtd
+ dev-lang/perl
+ dev-libs/libxslt
+ gnome-base/librsvg
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS COPYING NEWS README )
+
+python_check_deps() {
+ python_has_version "dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+
+ # The upstream build system isn't pure gettext and doesn't distinguish
+ # between empty and unset LINGUAS. Default to English only if either
+ # nls is unset or if LINGUAS exists but is empty. #891709
+ if ! use nls || [[ -v LINGUAS && -z ${LINGUAS} ]]; then
+ export LINGUAS="en"
+ elif [[ ! -v LINGUAS ]]; then
+ local line
+ while read line; do ewarn "${line}"; done <<-EOF
+ The "LINGUAS" variable is unset in your configuration,
+ but the "nls" USE flag is set. Therefore, documentation for
+ *all* languages will be built, which may take quite some time.
+ If you want to install documentation for a defined list
+ of languages, please assign "LINGUAS" accordingly.
+ The following languages are supported for ${CATEGORY}/${PN}:
+ "ca cs da de el en en_GB es fa fi fr hr hu it ja ko lt nl nn
+ pt pt_BR ro ru sl sv uk zh_CN"
+ If you want to install only the English documentation, it is
+ recommended to unset the "nls" USE flag for ${CATEGORY}/${PN}.
+
+ For more details please read:
+ https://wiki.gentoo.org/wiki/Localization/Guide#LINGUAS
+ EOF
+ fi
+}
+
+src_configure() {
+ econf --without-gimp
+}
+
+src_compile() {
+ # See bug: 833566
+ python_export_utf8_locale
+ # Affected with bugs: 677198, 876205. Set "emake -j1"
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ # See bug: 905693
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}
diff --git a/app-doc/gimp-help/gimp-help-2.8.2.ebuild b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
deleted file mode 100644
index a48b67dbafd2..000000000000
--- a/app-doc/gimp-help/gimp-help-2.8.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1
-
-DESCRIPTION="GNU Image Manipulation Program help files"
-HOMEPAGE="https://docs.gimp.org/"
-SRC_URI="mirror://gimp/help/${P}.tar.bz2"
-
-LICENSE="FDL-1.2"
-SLOT="2"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
- dev-libs/libxslt
- sys-devel/gettext
-"
-
-src_configure() {
- econf --without-gimp
-}
-
-src_compile() {
- # see https://bugs.gentoo.org/677198
- emake -j 1
-}
diff --git a/app-doc/gimp-help/metadata.xml b/app-doc/gimp-help/metadata.xml
index 6f49eba8f496..c7d0b0f3a771 100644
--- a/app-doc/gimp-help/metadata.xml
+++ b/app-doc/gimp-help/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
</pkgmetadata>