summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild')
-rw-r--r--app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild b/app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild
new file mode 100644
index 000000000000..e3bbbd96aeec
--- /dev/null
+++ b/app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT="9780596005900"
+
+DESCRIPTION="Howto write linux device drivers (updated for Linux 2.6)"
+HOMEPAGE="
+ https://www.oreilly.com/catalog/linuxdrive3/
+ https://lwn.net/Kernel/LDD3/
+"
+SRC_URI="
+ https://resources.oreilly.com/examples/${EGIT_COMMIT}/-/blob/master/examples.tar.gz -> LDD3-examples.tar.gz
+ https://lwn.net/images/pdf/LDD3/ldd3_pdf.tar.bz2
+"
+S="${WORKDIR}"
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="3"
+KEYWORDS="amd64 arm hppa ~ia64 ppc ~riscv ~s390 x86"
+
+src_install() {
+ dodoc ldd3_pdf/*.pdf
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+}