summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/mathjax-docs')
-rw-r--r--app-doc/mathjax-docs/Manifest1
-rw-r--r--app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild29
-rw-r--r--app-doc/mathjax-docs/mathjax-docs-3.2.2.ebuild40
-rw-r--r--app-doc/mathjax-docs/metadata.xml9
4 files changed, 62 insertions, 17 deletions
diff --git a/app-doc/mathjax-docs/Manifest b/app-doc/mathjax-docs/Manifest
index 94ca647bff47..a813dd8dcec0 100644
--- a/app-doc/mathjax-docs/Manifest
+++ b/app-doc/mathjax-docs/Manifest
@@ -1 +1,2 @@
DIST mathjax-docs-2.7.7.tar.gz 233452 BLAKE2B 280db6c794471d369a17161ad859dc73ddf1494af35114b69356aae41ea52d771f92b0b85ba82df8ed542039af152938f5fda71d752da4410ab183fe6a24ab81 SHA512 25fa97294ae153298d45b449d995c0402c481c6425ea4ebb38dcc509df741aed02d5469a520c8b793b8135b4140a6d1ad6688a42e3cb26004cfd7fcb838c32e6
+DIST mathjax-docs-3.2.2.tar.gz 227724 BLAKE2B 1b2d25073e4f141f5c832f1139e6bcfbdb15c039b820f3662d6fb261faebedac8ea72fb324d76389c35cd28cd41556689501d8795d7a426d735d4eaf88eb61ee SHA512 94167e58deb4f899d5c49a6b1efec24f57fff7aa497a019e9f775e251927c698b7c5598b88087c2964b8cb7238b73152dea01e091b8afaeab8979b396270d429
diff --git a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
index efa529306357..0ae6c89946c7 100644
--- a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
+++ b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit python-utils-r1 vcs-clean
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+inherit python-any-r1 vcs-clean
COMMIT="9d711f40638202b02f2154d7f05ea35088ff9388"
@@ -14,24 +15,28 @@ S="${WORKDIR}/MathJax-docs-${COMMIT}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
BDEPEND="
- dev-python/sphinx
- dev-python/sphinx_rtd_theme
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
"
+python_check_deps() {
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]"
+}
+
+DOCS=( README.md )
+
src_prepare() {
default
egit_clean
+ sed -e 's/add_stylesheet/add_css_file/' -i conf.py || die
}
src_compile() {
build_sphinx "${S}"
}
-
-src_install() {
- local DOCS=( README.md )
- default
- dosym ${P} /usr/share/doc/${PN}-${SLOT}
-}
diff --git a/app-doc/mathjax-docs/mathjax-docs-3.2.2.ebuild b/app-doc/mathjax-docs/mathjax-docs-3.2.2.ebuild
new file mode 100644
index 000000000000..c3c279c0a8ac
--- /dev/null
+++ b/app-doc/mathjax-docs/mathjax-docs-3.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+inherit python-any-r1 vcs-clean
+
+# MathJax-docs doesn't have releases, so this is the commit that was
+# current when mathjax-${PV} was released.
+COMMIT="c4a733d6d0ced4242a4df1c46137d4be6b3aaaee"
+
+DESCRIPTION="MathJax documentation"
+HOMEPAGE="https://docs.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax-docs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/MathJax-docs-${COMMIT}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
+"
+
+DOCS=(
+ README.md
+)
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_compile() {
+ build_sphinx "${S}"
+}
diff --git a/app-doc/mathjax-docs/metadata.xml b/app-doc/mathjax-docs/metadata.xml
index 2c67d4cc5913..6c0807468ad9 100644
--- a/app-doc/mathjax-docs/metadata.xml
+++ b/app-doc/mathjax-docs/metadata.xml
@@ -1,10 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>gienah@gentoo.org</email>
- <name>Mark Wright</name>
- </maintainer>
+ <!-- maintainer-needed -->
+ <stabilize-allarches/>
<longdescription lang="en">
MathJax is an open-source JavaScript display engine for LaTeX and
MathML that works in all modern browsers. It was designed with the
@@ -16,8 +14,9 @@
confident that users will be able to view it naturally and
easily. One simply includes MathJax and some mathematics in a web
page, and MathJax does the rest.
-</longdescription>
+ </longdescription>
<upstream>
<remote-id type="github">mathjax/MathJax-docs</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>