summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/pms/pms-5_p20120920.ebuild')
-rw-r--r--app-doc/pms/pms-5_p20120920.ebuild42
1 files changed, 19 insertions, 23 deletions
diff --git a/app-doc/pms/pms-5_p20120920.ebuild b/app-doc/pms/pms-5_p20120920.ebuild
index ec756a31611a..8c738245eee8 100644
--- a/app-doc/pms/pms-5_p20120920.ebuild
+++ b/app-doc/pms/pms-5_p20120920.ebuild
@@ -1,42 +1,38 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
MY_P="${PN}-${PV%%_*}"
DESCRIPTION="Gentoo Package Manager Specification"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Package_Manager_Specification"
-SRC_URI="!binary? ( https://dev.gentoo.org/~ulm/distfiles/${MY_P}.tar.xz )
- binary? ( https://dev.gentoo.org/~ulm/distfiles/${MY_P}-prebuilt.tar.xz )"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${MY_P}.tar.xz"
LICENSE="CC-BY-SA-3.0"
SLOT="${PV#*_p}"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="binary html"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="html"
-DEPEND="!binary? (
- dev-tex/leaflet
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-mathscience
- html? (
- app-text/recode
- >=dev-tex/tex4ht-20090115_p0029
- )
+BDEPEND="dev-tex/leaflet
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-mathscience
+ html? (
+ app-text/recode
+ >=dev-tex/tex4ht-20090115_p0029
)"
+RDEPEND="!app-doc/pms-bin"
S="${WORKDIR}/${MY_P}"
src_compile() {
- if ! use binary; then
- # just in case; we shouldn't be generating any fonts
- export VARTEXFONTS="${T}/fonts"
- emake
- use html && emake html
- fi
+ # just in case; we shouldn't be generating any fonts
+ export VARTEXFONTS="${T}/fonts"
+ emake
+ use html && emake html
}
src_install() {