summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/psmark')
-rw-r--r--app-doc/psmark/Manifest1
-rw-r--r--app-doc/psmark/files/psmark-2.1-Makefile-QA.patch19
-rw-r--r--app-doc/psmark/files/psmark-2.1-string.patch15
-rw-r--r--app-doc/psmark/metadata.xml9
-rw-r--r--app-doc/psmark/psmark-2.1.ebuild33
5 files changed, 0 insertions, 77 deletions
diff --git a/app-doc/psmark/Manifest b/app-doc/psmark/Manifest
deleted file mode 100644
index c22a67413f94..000000000000
--- a/app-doc/psmark/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST psmark-v2.1.tar.gz 16296 BLAKE2B e4f77b7a3abd86f8214e2f00d85eaef4a7b897b3fad970cf86565ad32ab42e25ab7674e9a1a7116a4cce93f46a99a5d17a21c14fb4ff3b2a860e1e2627b268a7 SHA512 0a765dda878478e767ae02ac0838a9c36a110000b35d557b1b3d17d22c518f42249cd4eba856b476ba8042e026cb49f736077d3bf236f2a9a4f3df4ff4357fef
diff --git a/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch b/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
deleted file mode 100644
index 145fe3a32e8e..000000000000
--- a/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -3,14 +3,13 @@
- all:
- make clean
- make psmark
-
- psmark:
-- gcc $(CFLAGS) -o psmark psmark.c
-- strip psmark
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o psmark psmark.c
-
- clean:
- rm -f *.o psmark
-
- install:
-- install -s psmark /usr/bin/
-+ install psmark /usr/bin/
- install psmark.1 /usr/man/man1/
diff --git a/app-doc/psmark/files/psmark-2.1-string.patch b/app-doc/psmark/files/psmark-2.1-string.patch
deleted file mode 100644
index 1d1fb3dfbb57..000000000000
--- a/app-doc/psmark/files/psmark-2.1-string.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/psmark.c
-+++ b/psmark.c
-@@ -97,9 +97,9 @@
- progname);
- fprintf(stderr,"example:\n %s -i test.ps -o output.ps -b 0.4 -s 15 \"vertical label\""
- "\n\n",progname);
-- fprintf(stderr,"Notes: The offsets are measured from the bottom left hand corner, but
-- they are not in sync with the page corner: some fiddling is required
-- to get text to appear right in the corner.\n"
-+ fprintf(stderr,"Notes: The offsets are measured from the bottom left hand corner, but\n"
-+ "they are not in sync with the page corner: some fiddling is required\n"
-+ "to get text to appear right in the corner.\n"
- );
-
- exit(error ? EXIT_FAILURE : EXIT_SUCCESS);
diff --git a/app-doc/psmark/metadata.xml b/app-doc/psmark/metadata.xml
deleted file mode 100644
index dba9c8dfae9d..000000000000
--- a/app-doc/psmark/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>Command-line Postscript watermark tool; simple, but useful
-for things like adding a watermark to outgoing or incoming faxes (eg, use
-with the sendfax command from net-misc/hylafax).
-</longdescription>
-</pkgmetadata>
diff --git a/app-doc/psmark/psmark-2.1.ebuild b/app-doc/psmark/psmark-2.1.ebuild
deleted file mode 100644
index 9caf0341120d..000000000000
--- a/app-doc/psmark/psmark-2.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-MY_PN=${PN}-v
-MY_P=${MY_PN}${PV}
-
-DESCRIPTION="Prints watermark-like text on any PostScript document"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="http://www.antitachyon.com/download/${MY_P}.tar.gz"
-S="${WORKDIR}"/${PN}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-
-PATCHES=(
- "${FILESDIR}"/${P}-string.patch
- "${FILESDIR}"/${P}-Makefile-QA.patch
-)
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- dobin psmark
- doman psmark.1
- dodoc README CHANGELOG
-}