summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/bvi/bvi-1.4.2.ebuild')
-rw-r--r--app-editors/bvi/bvi-1.4.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-editors/bvi/bvi-1.4.2.ebuild b/app-editors/bvi/bvi-1.4.2.ebuild
new file mode 100644
index 000000000000..39c1c1c2c9f4
--- /dev/null
+++ b/app-editors/bvi/bvi-1.4.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Display-oriented editor for binary files, based on the vi texteditor"
+HOMEPAGE="http://bvi.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ append-cflags -DANSI -std=gnu89
+ default
+}