summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/bvi')
-rw-r--r--app-editors/bvi/Manifest1
-rw-r--r--app-editors/bvi/bvi-1.4.1.ebuild6
-rw-r--r--app-editors/bvi/bvi-1.4.2.ebuild23
3 files changed, 27 insertions, 3 deletions
diff --git a/app-editors/bvi/Manifest b/app-editors/bvi/Manifest
index c20356e5e654..d6c7ca99d841 100644
--- a/app-editors/bvi/Manifest
+++ b/app-editors/bvi/Manifest
@@ -1 +1,2 @@
DIST bvi-1.4.1.src.tar.gz 143181 BLAKE2B ad4ae885b1b85ebfc4fc842e0b072383b6755eeaf1d8a71ffb461c5caf0c4c97d1906a7762b66ae4a5ede9ac8a204543bc0aed8630a3ea52ca452e8c645ad616 SHA512 f7a3f07e6bcefe566a101c4db85192f0d2e3580be0ab10bc297e6c0192e79d29061a7c9f1a57cf5a628f03962deb8c2ed52e33effc1d5198d458627d70d882e6
+DIST bvi-1.4.2.src.tar.gz 148323 BLAKE2B 8431b8cdb322a5a3bd011fb28cacc62f30bf02fa66bdb1e1e0993728fac28bd80da161c1011e9adbdf26d093374130b5413f3d2a739663d91b22403a5a740e2a SHA512 e2b23b75e5984e222060d3ad99381e1c54f45c28796b0dfe781072c406191272ffff2849218f90c29a398b245af604aa8f0f5448791bc5f3a2ef0f8395ca92c3
diff --git a/app-editors/bvi/bvi-1.4.1.ebuild b/app-editors/bvi/bvi-1.4.1.ebuild
index 05effad39dd2..042b1e9d61b3 100644
--- a/app-editors/bvi/bvi-1.4.1.ebuild
+++ b/app-editors/bvi/bvi-1.4.1.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Display-oriented editor for binary files, based on the vi texteditor"
HOMEPAGE="http://bvi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.src.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
IUSE=""
-KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
DEPEND="sys-libs/ncurses:0="
RDEPEND="${DEPEND}"
diff --git a/app-editors/bvi/bvi-1.4.2.ebuild b/app-editors/bvi/bvi-1.4.2.ebuild
new file mode 100644
index 000000000000..39c1c1c2c9f4
--- /dev/null
+++ b/app-editors/bvi/bvi-1.4.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Display-oriented editor for binary files, based on the vi texteditor"
+HOMEPAGE="http://bvi.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ append-cflags -DANSI -std=gnu89
+ default
+}