summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/e3/e3-2.8.2.ebuild')
-rw-r--r--app-editors/e3/e3-2.8.2.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-editors/e3/e3-2.8.2.ebuild b/app-editors/e3/e3-2.8.2.ebuild
index acbdc19af600..02569310fc46 100644
--- a/app-editors/e3/e3-2.8.2.ebuild
+++ b/app-editors/e3/e3-2.8.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -12,16 +12,20 @@ SRC_URI="https://sites.google.com/site/e3editor/Home/${MY_P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="-* amd64 ~riscv x86"
+KEYWORDS="-* amd64 x86"
BDEPEND=">=dev-lang/nasm-2.09.04"
S="${WORKDIR}/${MY_P}"
PATCHES=("${FILESDIR}"/${P}-makefile.patch)
-QA_FLAGS_IGNORED="/usr/bin/e3" #726484
+
+# Suppress false positive QA warnings #726484 #924244
+QA_FLAGS_IGNORED="/usr/bin/e3"
+QA_PRESTRIPPED="/usr/bin/e3"
src_compile() {
- emake -- $(usex amd64 64 32) LD="$(tc-getLD)" DEBUG=true
+ emake -- $(usev amd64 64 || usev x86 32 || die) \
+ LD="$(tc-getLD)" DEBUG=true
}
src_install() {