summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
index 2153ada2274b..b332683366c3 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.0.90.ebuild
@@ -273,8 +273,16 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ cat >src/temacs-wrapper <<-'EOF' || die
+ #!/bin/bash
+ export SANDBOX_ON=0
+ unset LD_PRELOAD
+ exec ./temacs "$@"
+ EOF
+ chmod +x src/temacs-wrapper || die
+
+ emake RUN_TEMACS="./temacs-wrapper"
}
src_install () {