summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-27.1.9999-r1.ebuild')
-rw-r--r--app-editors/emacs/emacs-27.1.9999-r1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/app-editors/emacs/emacs-27.1.9999-r1.ebuild b/app-editors/emacs/emacs-27.1.9999-r1.ebuild
index 78fc06dd7e03..bd826f2edf16 100644
--- a/app-editors/emacs/emacs-27.1.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-27.1.9999-r1.ebuild
@@ -40,11 +40,10 @@ DESCRIPTION="The extensible, customizable, self-documenting real-time display ed
HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
-REQUIRED_USE="?? ( aqua X )"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gui gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
RESTRICT="test"
-RDEPEND=">=app-emacs/emacs-common-gentoo-1.5[games?,X?]
+RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
sys-libs/ncurses:0=
acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
@@ -63,7 +62,7 @@ RDEPEND=">=app-emacs/emacs-common-gentoo-1.5[games?,X?]
ssl? ( net-libs/gnutls:0= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- X? (
+ gui? ( !aqua? (
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
@@ -124,10 +123,10 @@ RDEPEND=">=app-emacs/emacs-common-gentoo-1.5[games?,X?]
) )
)
)
- )"
+ ) )"
DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
+ gui? ( !aqua? ( x11-base/xorg-proto ) )"
BDEPEND="app-eselect/eselect-emacs
sys-apps/texinfo
@@ -181,7 +180,14 @@ src_configure() {
myconf+=" --with-sound=$(usex sound oss)"
fi
- if use X; then
+ if ! use gui; then
+ einfo "Configuring to build without window system support"
+ myconf+=" --without-x --without-ns"
+ elif use aqua; then
+ einfo "Configuring to build with Nextstep (Macintosh Cocoa) support"
+ myconf+=" --with-ns --disable-ns-self-contained"
+ myconf+=" --without-x"
+ else
myconf+=" --with-x --without-ns"
myconf+=" $(use_with gconf)"
myconf+=" $(use_with gsettings)"
@@ -253,12 +259,6 @@ src_configure() {
use xwidgets && ewarn \
"USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
fi
- elif use aqua; then
- einfo "Configuring to build with Nextstep (Cocoa) support"
- myconf+=" --with-ns --disable-ns-self-contained"
- myconf+=" --without-x"
- else
- myconf+=" --without-x --without-ns"
fi
econf \
@@ -385,7 +385,7 @@ src_install() {
it is strongly recommended that you use app-admin/emacs-updater
to rebuild all byte-compiled elisp files of the installed Emacs
packages."
- use X && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+ use gui && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
Installing media-fonts/font-adobe-{75,100}dpi on the X server's
machine would satisfy basic Emacs requirements under X11.
See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs