summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gedit/gedit-3.32.2.ebuild')
-rw-r--r--app-editors/gedit/gedit-3.32.2.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/app-editors/gedit/gedit-3.32.2.ebuild b/app-editors/gedit/gedit-3.32.2.ebuild
deleted file mode 100644
index 106d022fdbfb..000000000000
--- a/app-editors/gedit/gedit-3.32.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{5,6} )
-VALA_MIN_API_VERSION="0.26"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils gnome.org gnome2-utils meson multilib python-single-r1 vala virtualx xdg
-
-DESCRIPTION="A text editor for the GNOME desktop"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0"
-SLOT="0"
-
-IUSE="+introspection +python gtk-doc spell vala"
-REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} ) spell? ( python )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-
-# X libs are not needed for OSX (aqua)
-COMMON_DEPEND="
- >=dev-libs/libxml2-2.5.0:2
- >=dev-libs/glib-2.44:2[dbus]
- >=x11-libs/gtk+-3.22.0:3[introspection?]
- >=x11-libs/gtksourceview-4.0.2:4[introspection?]
- >=dev-libs/libpeas-1.14.1[gtk]
- >=net-libs/libsoup-2.60:2.4
-
- gnome-base/gsettings-desktop-schemas
- gnome-base/gvfs
-
- x11-libs/libX11
-
- introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
- python? (
- ${PYTHON_DEPS}
- dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
- dev-libs/libpeas[python,${PYTHON_USEDEP}] )
- spell? ( >=app-text/gspell-0.2.5:0= )
-"
-RDEPEND="${COMMON_DEPEND}
- x11-themes/adwaita-icon-theme
-"
-DEPEND="${COMMON_DEPEND}
- ${vala_depend}
- app-text/docbook-xml-dtd:4.1.2
- dev-util/glib-utils
- gtk-doc? ( >=dev-util/gtk-doc-1 )
- dev-util/itstool
- >=sys-devel/gettext-0.18
- virtual/pkgconfig
-"
-PATCHES=( "${FILESDIR}/${PV}-make-spell-optional.patch" )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- vala_src_prepare
- xdg_src_prepare
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use gtk-doc documentation)
- $(meson_use introspection)
- $(meson_use python plugins)
- $(meson_use spell)
- $(meson_use vala vapi)
- -Denable-gvfs-metadata=yes
- )
- meson_src_configure
-}
-
-src_test() { :; }
-
-src_install() {
- meson_src_install
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}