summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/Manifest2
-rw-r--r--app-editors/ghex/ghex-3.18.4-r1.ebuild39
-rw-r--r--app-editors/ghex/ghex-45.2.ebuild66
-rw-r--r--app-editors/ghex/ghex-9999.ebuild66
-rw-r--r--app-editors/ghex/metadata.xml11
5 files changed, 140 insertions, 44 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index 7190209b5e9c..db47f33ba468 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1 +1 @@
-DIST ghex-3.18.4.tar.xz 1420268 BLAKE2B 70a3027a2c228481ecbc6ae44c0a707c9858453e3af7bfc268b6e32a8496722cf117c1b2ce4dd798795a429dccd24e1fa9cb9d1a8c9c8fb5998243369f76ccc4 SHA512 6121a5986ee7d7f96bf7f401e155f8aa37f076af455bc68e43d1b5b02b63bc9aed3eba5209511d1b659eb4c9093ab5d9601c14a5e868d979e92a6d0ca0cf9ce2
+DIST ghex-45.2.tar.xz 902616 BLAKE2B 24e42b6d719280ab459d0ed7b96a502df7a5502e3d6cf385c0aa73b11808e40cac6112a3e0c3a228d5363578ccb875836efd8a13d6fc6c7e8ea4fe5a76bdb9c7 SHA512 2843b23a0673457ec72bd2aad20888fbc2ca890d3d859e6c2657af24cedc6185f6e11244574b603c0e32db2f54968e6584adf2c7e5abee84521c55148f536496
diff --git a/app-editors/ghex/ghex-3.18.4-r1.ebuild b/app-editors/ghex/ghex-3.18.4-r1.ebuild
deleted file mode 100644
index ace90f503b91..000000000000
--- a/app-editors/ghex/ghex-3.18.4-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit gnome.org gnome2-utils meson xdg
-DESCRIPTION="GNOME hexadecimal editor"
-HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
-
-LICENSE="GPL-2+ FDL-1.1+"
-SLOT="2"
-KEYWORDS="amd64 ~arm ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- >=dev-libs/atk-1.0.0
- >=dev-libs/glib-2.31.10:2
- >=x11-libs/gtk+-3.3.8:3
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxml2:2
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-# Requires unreleased appstream-glib-0.7.16 for tests to pass..
-RESTRICT="test" # https://gitlab.gnome.org/GNOME/ghex/issues/18
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/app-editors/ghex/ghex-45.2.ebuild b/app-editors/ghex/ghex-45.2.ebuild
new file mode 100644
index 000000000000..504d9010a46e
--- /dev/null
+++ b/app-editors/ghex/ghex-45.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4[introspection]
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
new file mode 100644
index 000000000000..6bc800a0f081
--- /dev/null
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4[introspection]
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/ghex/metadata.xml b/app-editors/ghex/metadata.xml
index 7b343b06be8a..ffc72ffa12d6 100644
--- a/app-editors/ghex/metadata.xml
+++ b/app-editors/ghex/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/ghex</remote-id>
+ </upstream>
</pkgmetadata>