summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghostwriter/ghostwriter-1.8.1.ebuild')
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.8.1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild b/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
deleted file mode 100644
index eb51f8371cc7..000000000000
--- a/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils xdg-utils
-
-DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
-HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
-SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-BDEPEND="dev-qt/linguist-tools:5"
-
-RDEPEND="
- app-text/hunspell:=
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtsvg:5
- dev-qt/qtwebchannel:5
- dev-qt/qtwebengine:5[widgets]
- dev-qt/qtwidgets:5
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( CREDITS.md README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-appdata-path.patch"
- "${FILESDIR}/${P}-qt-5.15.patch" # git master
-)
-
-src_prepare() {
- default
-
- sed -i -e "/^VERSION =/s/\$.*/${PV}/" ghostwriter.pro || die "failed to override version"
-}
-
-src_configure() {
- eqmake5 \
- CONFIG+=$(usex debug debug release) \
- PREFIX="${EPREFIX}"/usr
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
- einstalldocs
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}