summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gnome-latex/gnome-latex-3.28.1.ebuild')
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.28.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/gnome-latex-3.28.1.ebuild b/app-editors/gnome-latex/gnome-latex-3.28.1.ebuild
new file mode 100644
index 000000000000..67673e7585d8
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.28.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/GNOME-LaTeX"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+ app-text/enchant:0
+ >=app-text/gspell-1.0:0=
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/tepl-4.0:4
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration
+}