summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexedit/hexedit-1.6.ebuild')
-rw-r--r--app-editors/hexedit/hexedit-1.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-editors/hexedit/hexedit-1.6.ebuild b/app-editors/hexedit/hexedit-1.6.ebuild
new file mode 100644
index 000000000000..605cb66f658d
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}