summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kakoune')
-rw-r--r--app-editors/kakoune/Manifest3
-rw-r--r--app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch29
-rw-r--r--app-editors/kakoune/kakoune-2022.10.31.ebuild44
-rw-r--r--app-editors/kakoune/kakoune-2023.08.05.ebuild (renamed from app-editors/kakoune/kakoune-2021.11.08.ebuild)2
4 files changed, 76 insertions, 2 deletions
diff --git a/app-editors/kakoune/Manifest b/app-editors/kakoune/Manifest
index 078631a209d4..27da3bad8af1 100644
--- a/app-editors/kakoune/Manifest
+++ b/app-editors/kakoune/Manifest
@@ -1 +1,2 @@
-DIST kakoune-2021.11.08.tar.bz2 538466 BLAKE2B 30cb80c971c065610a8b40d9df0af2d3c1650baa065f14c22557b3c22e3cd2832e227a3a167d10d3892579eee30a70b5e3b62ad502dac7bdbb1c252b71c66e99 SHA512 429e11ff51fce18394e0a8fc55cd58a346b91dbe41b842b96c31a984bc92ea67b186c9f819d2d3ee88422ba453347281b0416a5bc4b1e7816240b9aba688a7e5
+DIST kakoune-2022.10.31.tar.bz2 556473 BLAKE2B 36489de5e4fa4406a847f43bf0f966c082e5c4a97e3c31d04c61fb8c4137fed4b6d1ce96ac921a85dc03fe7b90d8de172b6720ac32846507a3d0c996fe01191c SHA512 9a02a1a6bbb0b71a579b0286b4dfb6359b856183862b3e17354d2685b8215fa24c196b570a21dfd627e3d5a5b91e20ce0b74caff19e5772ab911cc42677bf720
+DIST kakoune-2023.08.05.tar.bz2 568612 BLAKE2B bbedc16f361a242c4319a852c3b688186e1e2b204990aff8434ad8a169d4c62171d2d3424e3bf65a4b5b6b17e21205e84077198091687094f88235e27c544bbd SHA512 f29b787ab6f04bc5a1a3ab31d189128745c967b5eec15fce07ae7dbaf29247f7413499d9925cf0561173feb0fe634f3423ac43da0d6c1ba5d679ee38b80ac679
diff --git a/app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch b/app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch
new file mode 100644
index 000000000000..6c093bcdb2eb
--- /dev/null
+++ b/app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/895264
+https://github.com/mawww/kakoune/issues/4854
+
+diff --git a/src/keys.hh b/src/keys.hh
+index 0af1a5a8..ccafe336 100644
+--- a/src/keys.hh
++++ b/src/keys.hh
+@@ -9,6 +9,8 @@
+ #include "unicode.hh"
+ #include "vector.hh"
+
++#include <cstdint>
++
+ namespace Kakoune
+ {
+
+diff --git a/src/ranked_match.hh b/src/ranked_match.hh
+index ec7fe626..62d6b8f0 100644
+--- a/src/ranked_match.hh
++++ b/src/ranked_match.hh
+@@ -4,6 +4,8 @@
+ #include "string.hh"
+ #include "meta.hh"
+
++#include <cstdint>
++
+ namespace Kakoune
+ {
+
diff --git a/app-editors/kakoune/kakoune-2022.10.31.ebuild b/app-editors/kakoune/kakoune-2022.10.31.ebuild
new file mode 100644
index 000000000000..9293c946c84a
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2022.10.31.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc13.patch
+)
+
+src_prepare() {
+ sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake -C src all
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
+
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}
diff --git a/app-editors/kakoune/kakoune-2021.11.08.ebuild b/app-editors/kakoune/kakoune-2023.08.05.ebuild
index 67d9bb162963..ea2fb090fb4a 100644
--- a/app-editors/kakoune/kakoune-2021.11.08.ebuild
+++ b/app-editors/kakoune/kakoune-2023.08.05.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8