summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/logseq-desktop-bin')
-rw-r--r--app-editors/logseq-desktop-bin/Manifest2
-rw-r--r--app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.8.ebuild91
-rw-r--r--app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.9.ebuild91
-rw-r--r--app-editors/logseq-desktop-bin/metadata.xml11
4 files changed, 195 insertions, 0 deletions
diff --git a/app-editors/logseq-desktop-bin/Manifest b/app-editors/logseq-desktop-bin/Manifest
new file mode 100644
index 000000000000..45cd342fea89
--- /dev/null
+++ b/app-editors/logseq-desktop-bin/Manifest
@@ -0,0 +1,2 @@
+DIST logseq-desktop-bin-0.10.8.zip 189513360 BLAKE2B 851b9a5b8b7a5b1c94ecc71cab87dfe6b94a55f8c320b81e80647499741661e1f220b9077acb6f1cdd61e2a6c7dc646fb832cdc80e504a8a4015531d81875cee SHA512 64a31ce323d7f0e9640a6c1b386631b0a9571bf9677effc3e0d1fd0fb8e68da3b95d37ef1db97bb2c7a12f3c1a75de7db44af566fcdfa62eb8aa76390330bf42
+DIST logseq-desktop-bin-0.10.9.zip 188490864 BLAKE2B 83e1b94490a4295f5f2821e70e83c76b31ab19879fa800b1111643cc81622169031d8e2af18eddedeabe3c6ae2e4a575ec9cb0b50acab48aef711c5f4cd678c0 SHA512 8f93c498d64699dcf5c68e7dc800a0a96f667b7767683903ba38cd7dea9f4787b9ab03e83e75cbf6d0b3ba5e52b1442e29aad1383b14c3acdf67463cc7eae176
diff --git a/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.8.ebuild b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.8.ebuild
new file mode 100644
index 000000000000..bc4f1ec885d5
--- /dev/null
+++ b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.8.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es-419 es et fa fil fi fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw
+ ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop unpacker xdg
+
+DESCRIPTION="A privacy-first, open-source platform for knowledge sharing and management."
+HOMEPAGE="https://github.com/logseq/logseq"
+SRC_URI="https://github.com/logseq/logseq/releases/download/${PV}/logseq-linux-x64-${PV}.zip -> ${P}.zip"
+S="${WORKDIR}/Logseq-linux-x64"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RESTRICT="mirror splitdebug"
+
+RDEPEND="
+ dev-libs/nss
+ dev-libs/openssl:0/3
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+QA_PREBUILT="*"
+
+src_configure() {
+ default
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ pushd locales > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+}
+
+src_install() {
+ exeinto /opt/logseq-desktop
+ doexe Logseq chrome-sandbox libEGL.so libffmpeg.so libGLESv2.so libvk_swiftshader.so libvulkan.so.1
+
+ insinto /opt/logseq-desktop
+ doins chrome_100_percent.pak chrome_200_percent.pak icudtl.dat resources.pak snapshot_blob.bin \
+ v8_context_snapshot.bin version vk_swiftshader_icd.json
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set
+ # see https://github.com/electron/electron/issues/17972
+ fowners root /opt/logseq-desktop/chrome-sandbox
+ fperms 4711 /opt/logseq-desktop/chrome-sandbox
+
+ # Crashpad is included in the package once in a while and when it does, it must be installed.
+ # See #903616 and #890595
+ [[ -x chrome_crashpad_handler ]] && doins chrome_crashpad_handler
+
+ dosym ../logseq-desktop/Logseq /opt/bin/logseq
+
+ make_desktop_entry "/opt/bin/logseq %U" Logseq logseq Office \
+ "StartupWMClass=logseq\nTerminal=false\nMimeType=x-scheme-handler/logseq"
+ # some releases do not have an icon included, but we dont fail if that happens
+ doicon resources/app/icons/logseq.png || true
+}
diff --git a/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.9.ebuild b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.9.ebuild
new file mode 100644
index 000000000000..bc4f1ec885d5
--- /dev/null
+++ b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es-419 es et fa fil fi fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw
+ ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop unpacker xdg
+
+DESCRIPTION="A privacy-first, open-source platform for knowledge sharing and management."
+HOMEPAGE="https://github.com/logseq/logseq"
+SRC_URI="https://github.com/logseq/logseq/releases/download/${PV}/logseq-linux-x64-${PV}.zip -> ${P}.zip"
+S="${WORKDIR}/Logseq-linux-x64"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RESTRICT="mirror splitdebug"
+
+RDEPEND="
+ dev-libs/nss
+ dev-libs/openssl:0/3
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+QA_PREBUILT="*"
+
+src_configure() {
+ default
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ pushd locales > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+}
+
+src_install() {
+ exeinto /opt/logseq-desktop
+ doexe Logseq chrome-sandbox libEGL.so libffmpeg.so libGLESv2.so libvk_swiftshader.so libvulkan.so.1
+
+ insinto /opt/logseq-desktop
+ doins chrome_100_percent.pak chrome_200_percent.pak icudtl.dat resources.pak snapshot_blob.bin \
+ v8_context_snapshot.bin version vk_swiftshader_icd.json
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set
+ # see https://github.com/electron/electron/issues/17972
+ fowners root /opt/logseq-desktop/chrome-sandbox
+ fperms 4711 /opt/logseq-desktop/chrome-sandbox
+
+ # Crashpad is included in the package once in a while and when it does, it must be installed.
+ # See #903616 and #890595
+ [[ -x chrome_crashpad_handler ]] && doins chrome_crashpad_handler
+
+ dosym ../logseq-desktop/Logseq /opt/bin/logseq
+
+ make_desktop_entry "/opt/bin/logseq %U" Logseq logseq Office \
+ "StartupWMClass=logseq\nTerminal=false\nMimeType=x-scheme-handler/logseq"
+ # some releases do not have an icon included, but we dont fail if that happens
+ doicon resources/app/icons/logseq.png || true
+}
diff --git a/app-editors/logseq-desktop-bin/metadata.xml b/app-editors/logseq-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..0a67e594f20b
--- /dev/null
+++ b/app-editors/logseq-desktop-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">logseq/logseq</remote-id>
+ </upstream>
+</pkgmetadata>