summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest3
-rw-r--r--app-editors/mousepad/metadata.xml3
-rw-r--r--app-editors/mousepad/mousepad-0.5.9.ebuild52
-rw-r--r--app-editors/mousepad/mousepad-0.6.2.ebuild (renamed from app-editors/mousepad/mousepad-0.5.10.ebuild)24
4 files changed, 21 insertions, 61 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index a7981fd9d57a..c1b0861653a8 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,2 +1 @@
-DIST mousepad-0.5.10.tar.bz2 959696 BLAKE2B bd21145f23f1e92d67489a3ffcdca0afd977aa639706dece5aefd2f5417d2b2122accc1a5c727ec13a4c2f311ec479612953006d78b5509e836f360566d0d320 SHA512 144e72abce8e5fb66a345fb59efe48f136dd9cf9cdcd72496dcee05b08781bdbba036f4ab5af04dbccd38dc52a8e8dd67b5b7434867881a1114de692a012b076
-DIST mousepad-0.5.9.tar.bz2 953685 BLAKE2B f8db50048964c789600ce6d310f6b6a893d7d4406d55f0666b7e78bf3e54446d3ec56eb70a059da6fac367d7c3f3fc5861fb29dadf28aa9b0d5e2f62056f3dfb SHA512 915fa1c89d66f793c4dba7826b4934e286e940dbdd9c933bddeeaf76be79d2140cd0feb1dea2946989879ec354d57af36fd61517309ebd4915f18be4b9cf621f
+DIST mousepad-0.6.2.tar.bz2 1402314 BLAKE2B c783ec58317ca3c0eaa0023ade3043f4aa4f020a12c0258fe0cf1e2303aa07dfbc67b9aa0178ca9282da98754103fda6c90ba034fa4057dd855b400c0d371085 SHA512 086f60f6f405290ed76366f4c5195e9c8f9c5058d1892200a73e48d6378428efe47f2038e3eddb81186e22dd87d57580559a556b1b22f202b6f056c7f90b64ea
diff --git a/app-editors/mousepad/metadata.xml b/app-editors/mousepad/metadata.xml
index fb3a6777ad9f..7ff48004695c 100644
--- a/app-editors/mousepad/metadata.xml
+++ b/app-editors/mousepad/metadata.xml
@@ -5,4 +5,7 @@
<email>xfce@gentoo.org</email>
<name>XFCE Team</name>
</maintainer>
+ <use>
+ <flag name="shortcuts">Build the "shortcuts" plugin</flag>
+ </use>
</pkgmetadata>
diff --git a/app-editors/mousepad/mousepad-0.5.9.ebuild b/app-editors/mousepad/mousepad-0.5.9.ebuild
deleted file mode 100644
index 5cca94e36155..000000000000
--- a/app-editors/mousepad/mousepad-0.5.9.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit gnome2-utils xdg-utils
-
-DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
-HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
-SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-libs/glib-2.52
- >=x11-libs/gtk+-3.22:3
- >=x11-libs/gtksourceview-4.0.0:4
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-lang/perl
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_configure() {
- local myconf=(
- --enable-gtksourceview4
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- gnome2_schemas_update
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_schemas_update
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
diff --git a/app-editors/mousepad/mousepad-0.5.10.ebuild b/app-editors/mousepad/mousepad-0.6.2.ebuild
index dc34dc267e55..5f5d41db5276 100644
--- a/app-editors/mousepad/mousepad-0.5.10.ebuild
+++ b/app-editors/mousepad/mousepad-0.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,20 +6,27 @@ EAPI=8
inherit gnome2-utils xdg-utils
DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
-HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv x86"
+IUSE="policykit spell +shortcuts"
-RDEPEND="
- >=dev-libs/glib-2.52
+DEPEND="
+ >=dev-libs/glib-2.56.2
>=x11-libs/gtk+-3.22:3
>=x11-libs/gtksourceview-4.0.0:4
+ policykit? ( sys-auth/polkit )
+ spell? ( app-text/gspell )
+ shortcuts? ( >=xfce-base/libxfce4ui-4.17.5:= )
"
-DEPEND="
- ${RDEPEND}
+RDEPEND="
+ ${DEPEND}
"
BDEPEND="
dev-lang/perl
@@ -31,6 +38,9 @@ BDEPEND="
src_configure() {
local myconf=(
--enable-gtksourceview4
+ $(use_enable policykit polkit)
+ $(use_enable spell plugin-gspell)
+ $(use_enable shortcuts plugin-shortcuts)
)
econf "${myconf[@]}"
}