summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch')
-rw-r--r--app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
new file mode 100644
index 000000000000..1488148298bd
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
@@ -0,0 +1,14 @@
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -415,11 +415,7 @@ foreach(gen_include ${prop})
+ list(APPEND gen_cflags "-I${gen_include}")
+ endforeach()
+ endforeach()
+
+-if(APPLE AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot")
+- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
+-endif()
+ set(gen_cflags ${gen_cflags} -O2)
+
+ set(NVIM_VERSION_GIT_H ${PROJECT_BINARY_DIR}/cmake.config/auto/versiondef_git.h)