summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files/neovim-9999-cmake-darwin.patch')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
new file mode 100644
index 000000000000..7d2352c6a18b
--- /dev/null
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -0,0 +1,13 @@
+Patch author: mortezadadgar <mortezadadgar97@gmail.com>
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -477,9 +477,6 @@ foreach(target ${targets})
+ endforeach()
+ endforeach()
+
+-if(APPLE AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot" "${CMAKE_OSX_SYSROOT}")
+-endif()
+ if(MSVC)
+ list(APPEND gen_cflags -wd4003)
+ endif()