summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files')
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch61
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch13
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch11
-rw-r--r--app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch55
-rw-r--r--app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch17
-rw-r--r--app-editors/neovim/files/neovim-0.9.0-cmake_lua_version.patch11
-rw-r--r--app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch14
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch60
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake_lua_version.patch11
-rw-r--r--app-editors/neovim/files/sysinit.vim-r197
10 files changed, 148 insertions, 202 deletions
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch
deleted file mode 100644
index 4fa8bf45bcbd..000000000000
--- a/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 07928e3..08881ee 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -58,23 +58,6 @@ endif()
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Enable fixing case-insensitive filenames for Windows and Mac.
- set(USE_FNAME_CASE TRUE)
-diff --git a/src/nvim/CMakeLists.txt b/src/nvim/CMakeLists.txt
-index aa81008..0570dc7 100644
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -192,10 +192,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
-diff --git a/third-party/CMakeLists.txt b/third-party/CMakeLists.txt
-index edd5882..e503434 100644
---- a/third-party/CMakeLists.txt
-+++ b/third-party/CMakeLists.txt
-@@ -105,13 +105,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- # Cross compiling: use these for dependencies built for the
- # HOST system, when not crosscompiling these should be the
- # same as DEPS_*. Except when targeting Unix in which case \ No newline at end of file
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch
deleted file mode 100644
index 2c9c80a7a690..000000000000
--- a/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Ensure that :checkhealth is happy with the Gentoo build type.
-https://bugs.gentoo.org/757744
---- a/runtime/autoload/health/nvim.vim
-+++ b/runtime/autoload/health/nvim.vim
-@@ -118,7 +118,7 @@ function! s:check_performance() abort
- let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(buildtype)
- else
- call health#report_info(buildtype)
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch b/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
deleted file mode 100644
index 4703dee52613..000000000000
--- a/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -384,7 +384,7 @@
- option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
- if(PREFER_LUA)
-- find_package(Lua 5.1 REQUIRED)
-+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
diff --git a/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch
deleted file mode 100644
index a8404bd4a97a..000000000000
--- a/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,23 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Ignore case when comparing filenames on Windows and Mac.
- set(CASE_INSENSITIVE_FILENAME TRUE)
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -205,10 +205,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
---- a/third-party/CMakeLists.txt
-+++ b/third-party/CMakeLists.txt
-@@ -117,13 +117,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- if(CMAKE_OSX_ARCHITECTURES)
- string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
- # The LuaJIT build does not like being passed multiple `-arch` flags
diff --git a/app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch
new file mode 100644
index 000000000000..b6026437f7bf
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 521ef93..a637866 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -114,12 +114,6 @@ set(NVIM_API_LEVEL 11) # Bump this after any API change.
+ set(NVIM_API_LEVEL_COMPAT 0) # Adjust this after a _breaking_ API change.
+ set(NVIM_API_PRERELEASE false)
+
+-# Default to -O2 on release builds.
+-if(CMAKE_C_FLAGS_RELEASE MATCHES "-O3")
+- message(STATUS "Replacing -O3 in CMAKE_C_FLAGS_RELEASE with -O2")
+- string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
+-endif()
+-
+ # Build-type: RelWithDebInfo
+
+ # /Og means something different in MSVC
diff --git a/app-editors/neovim/files/neovim-0.9.0-cmake_lua_version.patch b/app-editors/neovim/files/neovim-0.9.0-cmake_lua_version.patch
new file mode 100644
index 000000000000..b14b3b992349
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.9.0-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -464,7 +464,7 @@ endif()
+ # The unit test lib requires LuaJIT; it will be skipped if LuaJIT is missing.
+ option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
+ if(PREFER_LUA)
+- find_package(Lua 5.1 EXACT REQUIRED)
++ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
+ target_include_directories(main_lib SYSTEM BEFORE INTERFACE ${LUA_INCLUDE_DIR})
+ target_link_libraries(main_lib INTERFACE ${LUA_LIBRARIES})
+ # Passive (not REQUIRED): if LUAJIT_FOUND is not set, fixtures for unittests is skipped.
diff --git a/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
new file mode 100644
index 000000000000..1488148298bd
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
@@ -0,0 +1,14 @@
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -415,11 +415,7 @@ foreach(gen_include ${prop})
+ list(APPEND gen_cflags "-I${gen_include}")
+ endforeach()
+ endforeach()
+
+-if(APPLE AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot")
+- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
+-endif()
+ set(gen_cflags ${gen_cflags} -O2)
+
+ set(NVIM_VERSION_GIT_H ${PROJECT_BINARY_DIR}/cmake.config/auto/versiondef_git.h)
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index 5b829904a13e..7d2352c6a18b 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,55 +1,13 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,23 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Ignore case when comparing filenames on Windows and Mac.
- set(CASE_INSENSITIVE_FILENAME TRUE)
---- a/cmake.deps/CMakeLists.txt
-+++ b/cmake.deps/CMakeLists.txt
-@@ -112,13 +112,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- if(CMAKE_OSX_ARCHITECTURES)
- string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
- # The LuaJIT build does not like being passed multiple `-arch` flags
+Patch author: mortezadadgar <mortezadadgar97@gmail.com>
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -205,10 +205,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
+@@ -477,9 +477,6 @@ foreach(target ${targets})
+ endforeach()
endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
+
+-if(APPLE AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot" "${CMAKE_OSX_SYSROOT}")
-endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
+ if(MSVC)
+ list(APPEND gen_cflags -wd4003)
+ endif()
diff --git a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
deleted file mode 100644
index d7e01275fb02..000000000000
--- a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -384,7 +384,7 @@
- option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
- if(PREFER_LUA)
-- find_package(Lua 5.1 EXACT REQUIRED)
-+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
diff --git a/app-editors/neovim/files/sysinit.vim-r1 b/app-editors/neovim/files/sysinit.vim-r1
new file mode 100644
index 000000000000..de47eef7299e
--- /dev/null
+++ b/app-editors/neovim/files/sysinit.vim-r1
@@ -0,0 +1,97 @@
+" Default Gentoo configuration file for neovim
+" Based on the default vimrc shipped by Gentoo with app-editors/vim-core
+
+" You can override any of these settings on a global basis via the
+" "/etc/vim/nvimrc.local" file, and on a per-user basis via "~/.nvimrc".
+" You may need to create these.
+
+" Neovim comes with sensible defaults, see:
+" https://github.com/neovim/neovim/issues/2676
+" Most of the general settings from Gentoo's vimrc have been dropped here.
+" We add only some necessary fixes and a few Gentoo specific settings.
+
+" {{{ Locale settings
+" If we have a BOM, always honour that rather than trying to guess.
+if &fileencodings !~? "ucs-bom"
+ set fileencodings^=ucs-bom
+endif
+
+" Always check for UTF-8 when trying to determine encodings.
+if &fileencodings !~? "utf-8"
+ " If we have to add this, the default encoding is not Unicode.
+ let g:added_fenc_utf8 = 1
+ set fileencodings+=utf-8
+endif
+" }}}
+
+" {{{ Fix &shell, see bug #101665.
+if "" == &shell
+ if executable("/bin/bash")
+ set shell=/bin/bash
+ elseif executable("/bin/sh")
+ set shell=/bin/sh
+ endif
+endif
+"}}}
+
+" {{{ Our default /bin/sh is bash, not ksh, so syntax highlighting for .sh
+" files should default to bash. See :help sh-syntax and bug #101819.
+if has("eval")
+ let is_bash=1
+endif
+" }}}
+
+" {{{ Autocommands
+if has("autocmd")
+
+augroup gentoo
+ au!
+
+ " Gentoo-specific settings for ebuilds. These are the federally-mandated
+ " required tab settings. See the following for more information:
+ " http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml
+ " Note that the rules below are very minimal and don't cover everything.
+ " Better to emerge app-vim/gentoo-syntax, which provides full syntax,
+ " filetype and indent settings for all things Gentoo.
+ au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab
+
+ " When editing a file, always jump to the last cursor position
+ autocmd BufReadPost *
+ \ if ! exists("g:leave_my_cursor_position_alone") |
+ \ if line("'\"") > 0 && line ("'\"") <= line("$") |
+ \ exe "normal g'\"" |
+ \ endif |
+ \ endif
+
+ " When editing a crontab file, set backupcopy to yes rather than auto. See
+ " :help crontab and bug #53437.
+ autocmd FileType crontab set backupcopy=yes
+
+ " If we previously detected that the default encoding is not UTF-8
+ " (g:added_fenc_utf8), assume that a file with only ASCII characters (or no
+ " characters at all) isn't a Unicode file, but is in the default encoding.
+ " Except of course if a byte-order mark is in effect.
+ autocmd BufReadPost *
+ \ if exists("g:added_fenc_utf8") && &fileencoding == "utf-8" &&
+ \ ! &bomb && search('[\x80-\xFF]','nw') == 0 && &modifiable |
+ \ set fileencoding= |
+ \ endif
+
+ " Strip trailing spaces on write
+ autocmd BufWritePre *.e{build,class}
+ \ if ! exists("g:leave_my_trailing_space_alone") |
+ \ :%s/\s\+$//e |
+ \ endif
+
+augroup END
+
+endif " has("autocmd")
+" }}}
+
+" {{{ nvimrc.local
+if filereadable("/etc/vim/nvimrc.local")
+ source /etc/vim/nvimrc.local
+endif
+" }}}
+
+" vim: set tw=80 sw=2 sts=2 et foldmethod=marker :