summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/Manifest2
-rw-r--r--app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch35
-rw-r--r--app-editors/okteta/okteta-0.26.15.ebuild (renamed from app-editors/okteta/okteta-0.26.6.ebuild)16
3 files changed, 45 insertions, 8 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index f08c70a7e9aa..c962fbeda598 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1 @@
-DIST okteta-0.26.6.tar.xz 975720 BLAKE2B e9eaf258e9285dfcbf41cd0fcd3fa31e01a9d3b57b7d5c305d644aaeba2588351d0e212c7a6df7f06ab54da47728a916169dc2670772d445f5d34427fbf18946 SHA512 f489ddf1be6fe369b564b11cf8234c7a291b63101a00fb43163a1019609d1152735750946b2bd876080eff1697903ba02ada1ea641293a59f31d5edf34604b1a
+DIST okteta-0.26.15.tar.xz 1090764 BLAKE2B 3e96aca3bc1ec1aceb22de23f7aa954c7a41b1b074207bf59acb3be27ababb7a368044b231f587604c42dba16c002fd8f0df488b1828f564b0eb79cd64622fec SHA512 8e63b20ad3e1d238a6006fca834b355825015088a3dff82866e1197c2802e4a3cc57644d50b44407203bea2c2d4a132c89d402e52e4525d257de9a8cde87f1db
diff --git a/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch b/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch
new file mode 100644
index 000000000000..65beb70faae9
--- /dev/null
+++ b/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch
@@ -0,0 +1,35 @@
+From 5ca1bc18272c0ddbb3496fa29076ac2d65c034cf Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 27 Aug 2023 21:55:17 +0200
+Subject: [PATCH] Search for KF5DocTools individually
+
+Makes our ECM_HANDBOOK=forceoptional facility work while upstream is against it.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 17203b22f..3c914f178 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,7 +93,6 @@ if( BUILD_DESKTOPPROGRAM )
+ list(APPEND ADDITIONAL_REQUIRED_KF_COMPONENTS
+ Crash
+ DBusAddons
+- DocTools
+ )
+ endif()
+ find_package(KF5 ${REQUIRED_KF_VERSION} REQUIRED
+@@ -117,6 +116,7 @@ ecm_set_disabled_deprecation_versions(
+ # helper libs
+ add_subdirectory( libs )
+ if( BUILD_DESKTOPPROGRAM )
++ find_package(KF5DocTools ${REQUIRED_KF_VERSION} REQUIRED)
+ add_subdirectory( doc )
+ endif()
+
+--
+2.42.0
+
diff --git a/app-editors/okteta/okteta-0.26.6.ebuild b/app-editors/okteta/okteta-0.26.15.ebuild
index 7bc05fb0a30d..d7827f1dbd5b 100644
--- a/app-editors/okteta/okteta-0.26.6.ebuild
+++ b/app-editors/okteta/okteta-0.26.15.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_DESIGNERPLUGIN="true"
ECM_HANDBOOK="forceoptional"
ECM_TEST="true"
-KFMIN=5.74.0
-QTMIN=5.15.2
+KFMIN=5.92.0
+QTMIN=5.15.5
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Hex editor by KDE"
-HOMEPAGE="https://apps.kde.org/okteta/ https://utils.kde.org/projects/okteta/"
+HOMEPAGE="https://apps.kde.org/okteta/"
if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
fi
LICENSE="GPL-2 handbook? ( FDL-1.2 )"
@@ -49,10 +49,12 @@ DEPEND="
>=kde-frameworks/kservice-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=kde-frameworks/kxmlgui-${KFMIN}:5
- crypt? ( >=app-crypt/qca-2.3.0:2 )
+ crypt? ( >=app-crypt/qca-2.3.0:2[qt5(+)] )
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-0.26.13-doctools-optional.patch" ) # downstream
+
src_configure() {
local mycmakeargs=(
-DOMIT_EXAMPLES=ON