summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/pyvim')
-rw-r--r--app-editors/pyvim/Manifest2
-rw-r--r--app-editors/pyvim/metadata.xml4
-rw-r--r--app-editors/pyvim/pyvim-3.0.2.ebuild40
-rw-r--r--app-editors/pyvim/pyvim-3.0.3.ebuild44
4 files changed, 45 insertions, 45 deletions
diff --git a/app-editors/pyvim/Manifest b/app-editors/pyvim/Manifest
index ed95aecc3d88..d03a12272a13 100644
--- a/app-editors/pyvim/Manifest
+++ b/app-editors/pyvim/Manifest
@@ -1 +1 @@
-DIST pyvim-3.0.2.tar.gz 35227 BLAKE2B 8edc2218b3a0f2ba922531b75f65a5273ad9a2697f72ecf994cf7d2406c6311c3f28b22b6adb1243150a90db74962256ceaa7cf47ec99c2388299742451d6efb SHA512 da961342ba52e5beca44a607cbb923953388e8674409db9ca2b152017eeedce84f92e42a9f6d0e5019c5c4d88d82f4a987cb378f311cf84a169cefa54dc5efce
+DIST pyvim-3.0.3.gh.tar.gz 492633 BLAKE2B d62f1db2ec4af635841d18c860c5ac571c664116c539bab87b5f00a9c15b1f37f9dd53649d98a3d21d3bec9df0af46d18443eb1b34961d0971a7ed75df6a8c74 SHA512 0af9b772b97c21b8a9fe966497849eb83c6f770a212b98c7f261309f2f70d6cc8bcf2175660bee5c44850d6c805570946a79fbe9db7f1ffa8e20e19ef61a0635
diff --git a/app-editors/pyvim/metadata.xml b/app-editors/pyvim/metadata.xml
index fd901d010bd6..e99fedebbfd8 100644
--- a/app-editors/pyvim/metadata.xml
+++ b/app-editors/pyvim/metadata.xml
@@ -5,10 +5,6 @@
<email>vim@gentoo.org</email>
<name>Gentoo Vim Project</name>
</maintainer>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
<upstream>
<remote-id type="pypi">pyvim</remote-id>
<remote-id type="github">prompt-toolkit/pyvim</remote-id>
diff --git a/app-editors/pyvim/pyvim-3.0.2.ebuild b/app-editors/pyvim/pyvim-3.0.2.ebuild
deleted file mode 100644
index cd50a4a019fe..000000000000
--- a/app-editors/pyvim/pyvim-3.0.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of Vim in Python"
-HOMEPAGE="https://pypi.org/project/pyvim https://github.com/prompt-toolkit/pyvim"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- app-eselect/eselect-vi
- dev-python/docopt[${PYTHON_USEDEP}]
- dev-python/prompt_toolkit[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-
-eselect_vi_update() {
- einfo "Calling eselect vi update..."
- eselect vi update --if-unset
- eend $?
-}
-
-pkg_postinst() {
- eselect_vi_update
-}
-
-pkg_postrm() {
- eselect_vi_update
-}
diff --git a/app-editors/pyvim/pyvim-3.0.3.ebuild b/app-editors/pyvim/pyvim-3.0.3.ebuild
new file mode 100644
index 000000000000..984c32f845ed
--- /dev/null
+++ b/app-editors/pyvim/pyvim-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 edo
+
+COMMIT="14118ad2e4d0da2e955fd9069b8772408307618b"
+DESCRIPTION="An implementation of Vim in Python"
+HOMEPAGE="https://pypi.org/project/pyvim/ https://github.com/prompt-toolkit/pyvim"
+SRC_URI="https://github.com/prompt-toolkit/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~riscv x86"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/prompt-toolkit[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+IDEPEND="
+ app-eselect/eselect-vi
+"
+
+distutils_enable_tests pytest
+
+eselect_vi_update() {
+ edob eselect vi update --if-unset
+}
+
+pkg_postinst() {
+ eselect_vi_update
+}
+
+pkg_postrm() {
+ eselect_vi_update
+}