summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/remarkable')
-rw-r--r--app-editors/remarkable/Manifest1
-rw-r--r--app-editors/remarkable/files/README.gentoo10
-rw-r--r--app-editors/remarkable/files/fix-custom-css-issue.patch29
-rw-r--r--app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch23
-rw-r--r--app-editors/remarkable/files/webkit-version.patch11
-rw-r--r--app-editors/remarkable/metadata.xml15
-rw-r--r--app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild70
7 files changed, 159 insertions, 0 deletions
diff --git a/app-editors/remarkable/Manifest b/app-editors/remarkable/Manifest
new file mode 100644
index 000000000000..9a5732e15b1a
--- /dev/null
+++ b/app-editors/remarkable/Manifest
@@ -0,0 +1 @@
+DIST remarkable-1.9.0_pre20210320.tar.gz 132617 BLAKE2B e3146ad354ebbe7972556d5952a576a1e242bd2aefca91948d75ae6c571fe3e1956e40184db4c5ca6a47f01130a7745101fe556c49854058b9fd110cb74783ae SHA512 0cfe1a01a198396dbc6f30d9e4ca4fa2de6624f29557d60053a7e446a0a3da3a577b32b25ba6eb93300316ede6afad4140ff75bd3e411e15cb1e5221d2b095d9
diff --git a/app-editors/remarkable/files/README.gentoo b/app-editors/remarkable/files/README.gentoo
new file mode 100644
index 000000000000..9533e5f0de44
--- /dev/null
+++ b/app-editors/remarkable/files/README.gentoo
@@ -0,0 +1,10 @@
+
+Known Gentoo-related issues:
+============================
+
+- export to HTML/PDF does not work (this feature would need the python module
+ "wkhtmltopdf" which is not packaged for gentoo and most probably will
+ never be - it depends on deprecated Qt WebKit)
+- spellchecking is disabled (would need python module pygtkspellcheck which)
+ is also not packaged for gentoo yet)
+
diff --git a/app-editors/remarkable/files/fix-custom-css-issue.patch b/app-editors/remarkable/files/fix-custom-css-issue.patch
new file mode 100644
index 000000000000..4d45f18a01b4
--- /dev/null
+++ b/app-editors/remarkable/files/fix-custom-css-issue.patch
@@ -0,0 +1,29 @@
+From 09459c2e577a0ae2561e4f785efc026dcfb65809 Mon Sep 17 00:00:00 2001
+From: Nikita Zlobin <cook60020tmp@mail.ru>
+Date: Fri, 4 Aug 2023 23:56:43 +0500
+Subject: [PATCH] Fix issue #345 - apply custom css on start
+
+Just a typo, when default empty css was used on application start
+instead of configured.
+
+Fixes #345
+---
+ remarkable/RemarkableWindow.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/remarkable/RemarkableWindow.py b/remarkable/RemarkableWindow.py
+index d54aa32..45134ab 100755
+--- a/remarkable/RemarkableWindow.py
++++ b/remarkable/RemarkableWindow.py
+@@ -331,7 +331,7 @@ class RemarkableWindow(Window):
+ elif self.style == "solarized_light":
+ styles.set(styles.solarized_light)
+ elif self.style == "custom":
+- styles.set(styles.custom_css)
++ styles.set(self.custom_css)
+ else:
+ print("Style key error")
+
+--
+2.39.3
+
diff --git a/app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch b/app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch
new file mode 100644
index 000000000000..6dbd4cf48a8d
--- /dev/null
+++ b/app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch
@@ -0,0 +1,23 @@
+Remove the spellcheck option permanently unless someone is packaging
+pygtkspellcheck for Gentoo
+
+Signed-off-by: Martin Dummer <martin.dummer@gmx.net>
+
+--- a/remarkable/RemarkableWindow.py
++++ b/remarkable/RemarkableWindow.py
+@@ -41,13 +41,8 @@
+ import warnings
+ from findBar import FindBar
+
+-# Check if gtkspellcheck is installed
+-try:
+- from gtkspellcheck import SpellChecker
+- spellcheck_enabled = True
+-except:
+- print("*Spellchecking not enabled.\n*To enable spellchecking install pygtkspellcheck\n*https://pypi.python.org/pypi/pygtkspellcheck/")
+- spellcheck_enabled = False
++# spellcheck permanently disabled
++spellcheck_enabled = False
+
+ import logging
+ logger = logging.getLogger('remarkable')
diff --git a/app-editors/remarkable/files/webkit-version.patch b/app-editors/remarkable/files/webkit-version.patch
new file mode 100644
index 000000000000..6b64a9f8b6e6
--- /dev/null
+++ b/app-editors/remarkable/files/webkit-version.patch
@@ -0,0 +1,11 @@
+--- a/remarkable/RemarkableWindow.py 2023-03-11 19:50:14.183333326 +0100
++++ b/remarkable/RemarkableWindow.py 2023-03-11 19:57:02.033333327 +0100
+@@ -24,7 +24,7 @@
+ import gi
+ gi.require_version('Gtk', '3.0')
+ gi.require_version('GtkSource', '3.0')
+-gi.require_version('WebKit2', '4.0')
++gi.require_version('WebKit2', '4.1')
+
+ from bs4 import BeautifulSoup
+ from gi.repository import Gdk, Gtk, GtkSource, Pango, WebKit2
diff --git a/app-editors/remarkable/metadata.xml b/app-editors/remarkable/metadata.xml
new file mode 100644
index 000000000000..0aa3bb718657
--- /dev/null
+++ b/app-editors/remarkable/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>martin.dummer@gmx.net</email>
+ <name>Martin Dummer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jamiemcg/remarkable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild b/app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild
new file mode 100644
index 000000000000..f35866eca613
--- /dev/null
+++ b/app-editors/remarkable/remarkable-1.9.0_pre20210320-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit desktop gnome2-utils python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="Fully featured markdown editor, supports github markdown dialect"
+HOMEPAGE="https://remarkableapp.github.io/ https://github.com/jamiemcg/remarkable"
+GIT_COMMIT="7b0b3dacef270a00c28e8852a88d74f72a3544d7"
+SRC_URI="https://github.com/jamiemcg/remarkable/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Remarkable-${GIT_COMMIT}"
+
+LICENSE="BSD-2 GPL-2+ LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ net-libs/webkit-gtk:4.1[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-spellcheck.patch
+ "${FILESDIR}"/webkit-version.patch
+ "${FILESDIR}"/fix-custom-css-issue.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s|import styles|from remarkable import styles|" \
+ -e "s|from findBar|from remarkable.findBar|" \
+ remarkable/RemarkableWindow.py || die
+}
+
+src_install() {
+ default
+
+ python_domodule markdown pdfkit remarkable remarkable_lib
+ python_doscript bin/remarkable
+ doicon data/ui/remarkable.png
+ domenu ${PN}.desktop
+
+ insinto /usr/share/${PN}
+ doins -r data/ui
+ doins -r data/media
+
+ insinto /usr/share/glib-2.0/schemas
+ doins data/glib-2.0/schemas/*
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}