summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/retext/retext-7.2.3.ebuild')
-rw-r--r--app-editors/retext/retext-7.2.3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/retext/retext-7.2.3.ebuild b/app-editors/retext/retext-7.2.3.ebuild
index 214372f2d90a..700a1e8d40b0 100644
--- a/app-editors/retext/retext-7.2.3.ebuild
+++ b/app-editors/retext/retext-7.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,9 @@ EAPI=8
# Please don't add pypy support before testing if it's actually supported. The
# old compat matrix is no longer accessible as of 2021-02-13 but stated back
# in 2020-07-05 that PyQt5 was explicitly not supported.
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{9,10} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="ReText"
inherit distutils-r1 optfeature qmake-utils virtualx xdg
@@ -20,10 +22,8 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/retext-project/retext.git"
else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-
- KEYWORDS="~amd64 ~riscv ~x86"
+ inherit pypi
+ KEYWORDS="amd64 ~riscv ~x86"
fi
LICENSE="GPL-2+"