summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/sandy/sandy-0.4.ebuild')
-rw-r--r--app-editors/sandy/sandy-0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-editors/sandy/sandy-0.4.ebuild b/app-editors/sandy/sandy-0.4.ebuild
new file mode 100644
index 000000000000..76cc1bc27d6e
--- /dev/null
+++ b/app-editors/sandy/sandy-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="an ncurses text editor with an easy-to-read, hackable C source"
+HOMEPAGE="http://tools.suckless.org/sandy"
+SRC_URI="http://git.suckless.org/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ append-cflags -D_DEFAULT_SOURCE
+ emake PREFIX=/usr ${PN}
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}