summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/Manifest5
-rw-r--r--app-editors/scite/files/scite-5.3.5-gcc-13-fix-bgo892431.patch40
-rw-r--r--app-editors/scite/metadata.xml9
-rw-r--r--app-editors/scite/scite-5.1.1.ebuild97
-rw-r--r--app-editors/scite/scite-5.1.6.ebuild97
-rw-r--r--app-editors/scite/scite-5.2.4.ebuild97
-rw-r--r--app-editors/scite/scite-5.3.5.ebuild (renamed from app-editors/scite/scite-5.1.3.ebuild)22
7 files changed, 53 insertions, 314 deletions
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index 25bd3f96c50e..89177a5a6bac 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,4 +1 @@
-DIST scite-5.1.1.tgz 3374717 BLAKE2B b7a45a86008eb592adacc8fde90cb637cc7cac821f339bb65920aaf912ee10d52badde3ed2e71118a7ce4690a0536b298c5fe5f673b886902ad4634b3a1ffaa6 SHA512 4d6c9b3ca4caed4fcb70a6b1c86a2ace13b023241f16d6faa01b3f692bcbfa14e0ce186bb08776ee0cf62768b2b77c4ffcae610ddbb6b04dcb7584fd8b3f27bb
-DIST scite-5.1.3.tgz 3427245 BLAKE2B ca765b61cb1fa96934c1e28d76a97cd7086a6c692ae33bb57591dfbc8637ffc94c4a3f20f9c6b55d11da8a76664f1d521f7e393bf6f31db55cbe02e0bf5052ba SHA512 ef86a18f739062598d3c7bf19bcd2f38ca012e890b9b4685c1f1b809e928762ab60d24c33a1f45ca33133ce5007e3a22a76e80222b121c9a4089d3c57aa0bc4c
-DIST scite-5.1.6.tgz 3436413 BLAKE2B 3bf578d750c844cebc187662d658556ba58934929872b74012b299e10f6057352d184542e37433e3e031fa566b28e91d51a5d00687c6a4df35301d8ceb75a795 SHA512 3983034e5a14d696a455375eb4ca922c458c9f74fd1d2e6c7b1735914a733978b65119b9370167227e50d20d4c6f636b96bb4d1d8eb8fe8ae1d7f7ca1c143e20
-DIST scite-5.2.4.tgz 3440615 BLAKE2B a98028774837f7c19a73d3ceef0e7cf945674b0b0d21eec7af4874a1fab1dcbfdad9255adcfb9d458dfc6549baeb27dee3fab207f0145b6c722794a9a96ec284 SHA512 ac3f25fbfe654f4b249c55b2bf97d5ea57483a484feeb30c3663e13366d1a569d9faa22c83b4eb5201154d00713fcd550478573db987084eba0a2e8ea22c57e9
+DIST scite-5.3.5.tgz 3535798 BLAKE2B 16bd6331b8ab5ef2d700a121d8d85078f6eea2f8c45cfd62c5b27c7c9622f853a871e98402ee3833c09652d869271ed05a61374ee1f55d58dbdcc0f5fcbd681c SHA512 18ed3e802f6f5e66573f72c4ad42d592ea3f79e191e828a32d2d55aaf285a2cb9961e206c9e99f82c77f0975494e9105ac925394d7cf48223b954e253f1dee9c
diff --git a/app-editors/scite/files/scite-5.3.5-gcc-13-fix-bgo892431.patch b/app-editors/scite/files/scite-5.3.5-gcc-13-fix-bgo892431.patch
new file mode 100644
index 000000000000..935fbdf0b8cd
--- /dev/null
+++ b/app-editors/scite/files/scite-5.3.5-gcc-13-fix-bgo892431.patch
@@ -0,0 +1,40 @@
+--- a/scite/scripts/HeaderOrder.txt 2023-05-28 04:10:36.897378314 +0300
++++ b/scite/scripts/HeaderOrder.txt 2023-05-28 04:11:48.740712313 +0300
+@@ -30,6 +30,7 @@
+
+ // C++ standard library
+ #include <stdexcept>
++#include <system_error>
+ #include <tuple>
+ #include <string>
+ #include <string_view>
+--- a/scite/src/MultiplexExtension.cxx 2023-05-28 04:16:48.680714993 +0300
++++ b/scite/src/MultiplexExtension.cxx 2023-05-28 04:17:58.230715597 +0300
+@@ -5,6 +5,7 @@
+ // Copyright 1998-2003 by Neil Hodgson <neilh@scintilla.org>
+ // The License.txt file describes the conditions under which this software may be distributed.
+
++#include <cstdint>
+ #include <string>
+ #include <string_view>
+ #include <vector>
+--- a/scite/src/SciTEBase.cxx 2023-05-28 04:20:08.850716714 +0300
++++ b/scite/src/SciTEBase.cxx 2023-05-28 04:21:35.867384145 +0300
+@@ -15,6 +15,7 @@
+ #include <ctime>
+ #include <cmath>
+
++#include <system_error>
+ #include <tuple>
+ #include <string>
+ #include <string_view>
+--- a/scite/src/SciTEProps.cxx 2023-05-28 04:22:53.904051478 +0300
++++ b/scite/src/SciTEProps.cxx 2023-05-28 04:23:43.374051910 +0300
+@@ -13,6 +13,7 @@
+ #include <ctime>
+ #include <clocale>
+
++#include <stdexcept>
+ #include <tuple>
+ #include <string>
+ #include <string_view>
diff --git a/app-editors/scite/metadata.xml b/app-editors/scite/metadata.xml
index 7694337e8744..ae6d6c4b2c1f 100644
--- a/app-editors/scite/metadata.xml
+++ b/app-editors/scite/metadata.xml
@@ -1,14 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>ervin.peters@ervnet.de</email>
- <name>Ervin Peters</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">scintilla</remote-id>
</upstream>
diff --git a/app-editors/scite/scite-5.1.1.ebuild b/app-editors/scite/scite-5.1.1.ebuild
deleted file mode 100644
index 55863b5a601e..000000000000
--- a/app-editors/scite/scite-5.1.1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-1 )
-
-inherit lua-single toolchain-funcs xdg
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}"
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- default
- dosym SciTE /usr/bin/scite
-}
diff --git a/app-editors/scite/scite-5.1.6.ebuild b/app-editors/scite/scite-5.1.6.ebuild
deleted file mode 100644
index f2887e4b0f91..000000000000
--- a/app-editors/scite/scite-5.1.6.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-4 )
-
-inherit lua-single toolchain-funcs xdg
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}"
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- default
- dosym SciTE /usr/bin/scite
-}
diff --git a/app-editors/scite/scite-5.2.4.ebuild b/app-editors/scite/scite-5.2.4.ebuild
deleted file mode 100644
index 19bb5f74a12c..000000000000
--- a/app-editors/scite/scite-5.2.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-4 )
-
-inherit lua-single toolchain-funcs xdg
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}"
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- GTK3=1 default
- dosym SciTE /usr/bin/scite
-}
diff --git a/app-editors/scite/scite-5.1.3.ebuild b/app-editors/scite/scite-5.3.5.ebuild
index 56eaa7f3c945..1242ae6a372f 100644
--- a/app-editors/scite/scite-5.1.3.ebuild
+++ b/app-editors/scite/scite-5.3.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-LUA_COMPAT=( lua5-1 )
+LUA_COMPAT=( lua5-4 )
inherit lua-single toolchain-funcs xdg
@@ -19,23 +19,23 @@ IUSE="lua"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
RDEPEND="
- dev-libs/atk
+ >=app-accessibility/at-spi2-core-2.46.0
dev-libs/glib:2
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
+ lua? ( ${LUA_DEPS} )
+"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
+DOCS=( "../README" )
S="${WORKDIR}/${PN}/gtk"
+PATCHES=( "${FILESDIR}"/scite-5.3.5-gcc-13-fix-bgo892431.patch )
+
pkg_setup() {
use lua && lua-single_pkg_setup
}
@@ -74,7 +74,7 @@ src_prepare() {
# Bug #576162
cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
+ default
}
src_compile() {
@@ -92,6 +92,6 @@ src_compile() {
# want to use the base src_install() as base_src_install()
src_install() {
- default
+ GTK3=1 default
dosym SciTE /usr/bin/scite
}