summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/shed/files')
-rw-r--r--app-editors/shed/files/shed-1.15-cflags.patch11
-rw-r--r--app-editors/shed/files/shed-1.15-interix.patch14
-rw-r--r--app-editors/shed/files/shed-1.15-tinfo.patch12
3 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/shed/files/shed-1.15-cflags.patch b/app-editors/shed/files/shed-1.15-cflags.patch
new file mode 100644
index 000000000000..2b675f7449f7
--- /dev/null
+++ b/app-editors/shed/files/shed-1.15-cflags.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -2,7 +2,7 @@
+ AM_INIT_AUTOMAKE(shed,1.15)
+ AC_PROG_CC
+ AC_PROG_INSTALL
+-CFLAGS="-Wall"
++CFLAGS="$CFLAGS -Wall"
+ AC_SUBST(CFLAGS)
+
+ AC_ARG_ENABLE(debug, [ --enable-debug gcc -g],enable_debug=yes)
diff --git a/app-editors/shed/files/shed-1.15-interix.patch b/app-editors/shed/files/shed-1.15-interix.patch
new file mode 100644
index 000000000000..d496795477b4
--- /dev/null
+++ b/app-editors/shed/files/shed-1.15-interix.patch
@@ -0,0 +1,14 @@
+http://sourceforge.net/tracker/?func=detail&aid=3554634&group_id=21862&atid=374571
+--- a/shed.c
++++ b/shed.c
+@@ -31,6 +31,10 @@
+ #include <ctype.h> /* tolower */
+ #include <unistd.h> /* dup, dup2 */
+
++#ifdef __INTERIX
++# include <sys/time.h>
++#endif
++
+ #include "util.h"
+
+ /* function prototypes */
diff --git a/app-editors/shed/files/shed-1.15-tinfo.patch b/app-editors/shed/files/shed-1.15-tinfo.patch
new file mode 100644
index 000000000000..d1a406521c0f
--- /dev/null
+++ b/app-editors/shed/files/shed-1.15-tinfo.patch
@@ -0,0 +1,12 @@
+--- a/configure.in
++++ b/configure.in
+@@ -41,8 +41,7 @@
+ fi
+
+ ERR="Required package missing!"
+-AC_CHECK_HEADER(ncurses.h,:,AC_MSG_ERROR([$ERR]))
++PKG_CHECK_MODULES(ncurses,ncurses,[LIBS="$LIBS $ncurses_LIBS"],AC_MSG_ERROR([$ERR]))
+ AC_CHECK_HEADER(getopt.h,:,AC_MSG_ERROR([$ERR]))
+-AC_CHECK_LIB(ncurses,initscr)
+ AC_CHECK_LIB(m,pow)
+ AC_OUTPUT(Makefile)