summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/shed/shed-1.16.ebuild')
-rw-r--r--app-editors/shed/shed-1.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-editors/shed/shed-1.16.ebuild b/app-editors/shed/shed-1.16.ebuild
new file mode 100644
index 000000000000..adb9fde8ed45
--- /dev/null
+++ b/app-editors/shed/shed-1.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools
+
+DESCRIPTION="Simple Hex EDitor"
+HOMEPAGE="https://shed.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}