summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/texworks/files')
-rw-r--r--app-editors/texworks/files/qt5.15-support.patch21
-rw-r--r--app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch25
2 files changed, 25 insertions, 21 deletions
diff --git a/app-editors/texworks/files/qt5.15-support.patch b/app-editors/texworks/files/qt5.15-support.patch
deleted file mode 100644
index 9c77c157e463..000000000000
--- a/app-editors/texworks/files/qt5.15-support.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From a5352a3a94e3685125650b65e6197de060326cc2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Stefan=20L=C3=B6ffler?= <st.loeffler@gmail.com>
-Date: Fri, 1 May 2020 08:05:46 +0200
-Subject: [PATCH] <QtPDF> Fix compilation with Qt 5.15
-
----
- modules/QtPDF/src/PDFBackend.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/modules/QtPDF/src/PDFBackend.cpp b/modules/QtPDF/src/PDFBackend.cpp
-index 0305d87a..500d20aa 100644
---- a/modules/QtPDF/src/PDFBackend.cpp
-+++ b/modules/QtPDF/src/PDFBackend.cpp
-@@ -14,6 +14,7 @@
-
- #include <PDFBackend.h>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QApplication>
-
- namespace QtPDF {
diff --git a/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
new file mode 100644
index 000000000000..460c4f4f7e2d
--- /dev/null
+++ b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
@@ -0,0 +1,25 @@
+It doesn't work like that.
+
+--- a/CMakeLists.txt 2023-02-18 11:42:11.000000000 +0100
++++ b/CMakeLists.txt 2023-10-21 20:00:29.144638825 +0200
+@@ -281,9 +281,11 @@
+ set(QT_VERSION_PATCH "${Qt6_VERSION_PATCH}")
+ else ()
+ # Check for Qt5
+- find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml OPTIONAL_COMPONENTS Script ScriptTools)
++ find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml)
+ set(QT_LIBRARIES Qt5::Core Qt5::Widgets Qt5::Gui Qt5::UiTools Qt5::Concurrent Qt5::Xml Qt5::Qml)
+
++ find_package(Qt5Script)
++ find_package(Qt5ScriptTools)
+ if (Qt5Script_FOUND AND Qt5ScriptTools_FOUND)
+ list(APPEND QT_LIBRARIES Qt5::ScriptTools Qt5::Script)
+ set(WITH_QTSCRIPT ON)
+@@ -311,7 +313,6 @@
+ set(QT_VERSION_MAJOR "${Qt5_VERSION_MAJOR}")
+ set(QT_VERSION_MINOR "${Qt5_VERSION_MINOR}")
+ set(QT_VERSION_PATCH "${Qt5_VERSION_PATCH}")
+- set(WITH_QTSCRIPT ON)
+ endif ()
+
+ # Expose the major version number of Qt to the preprocessor. This is necessary