summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/xemacs/files/xemacs-21.5.35-configure-libc-version.patch')
-rw-r--r--app-editors/xemacs/files/xemacs-21.5.35-configure-libc-version.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-editors/xemacs/files/xemacs-21.5.35-configure-libc-version.patch b/app-editors/xemacs/files/xemacs-21.5.35-configure-libc-version.patch
new file mode 100644
index 000000000000..e744d3952b10
--- /dev/null
+++ b/app-editors/xemacs/files/xemacs-21.5.35-configure-libc-version.patch
@@ -0,0 +1,73 @@
+diff -r 3761ed745bc6 configure.ac
+--- a/configure.ac Sat Mar 02 17:26:00 2024 +0100
++++ b/configure.ac Fri Mar 08 22:25:23 2024 +0100
+@@ -2192,7 +2192,6 @@
+
+ compiler_version=""
+ gcc_compiler_specs=""
+-libc_version=""
+
+ AC_MSG_CHECKING([for compiler version information])
+
+@@ -2255,53 +2254,6 @@
+ fi
+ AC_MSG_RESULT([$compiler_version])
+
+-AC_MSG_CHECKING(for standard C library version information)
+-
+-case "$ac_cv_build" in
+- *-*-linux*)
+- dnl #### who would ever _not_ be running the distro's libc?
+- dnl Maybe it would be better to get/augment this info with ldd?
+- if test -f /etc/redhat-release ; then
+- libc_version=`rpm -q glibc`
+- elif test -f /etc/debian_version ; then
+- libc_version=`dpkg-query --showformat='${version}' --show libc6`
+- libc_version="GNU libc $libc_version (Debian)"
+- dnl need SuSE et al checks here...
+- fi
+- dnl #### Tested on Debian, does this actually work elsewhere? ;-)
+- if test -z "$libc_version"; then
+- libc_version=`ls /lib/libc-*.so | sed -e 's,/lib/libc-\(.*\)\.so,\1,'`
+- fi
+- ;;
+-
+- *-*-aix*)
+- libc_version="bos.rte.libc `lslpp -Lqc bos.rte.libc | cut -f3 -d:`"
+- ;;
+-
+- *-*-solaris*)
+- libc=`pkginfo -l SUNWcsl | grep VERSION: | awk '{print $2}'`
+- libc_version="SUNWcsl $libc"
+-
+- ;;
+-
+- mips-sgi-irix*)
+- libc_version="IRIX libc `uname -sRm`"
+- ;;
+-
+- alpha*-dec-osf*)
+- dnl Another ugly case
+- (cd /usr/.smdb.;
+- libc_version=` grep -h libc.so *.inv | awk '$9 == "f" {print $12}' | tr '\n' ','`
+- )
+- ;;
+-esac
+-
+-dnl Awww, shucks.
+-if test -z "libc_version"; then
+- libc_version="detection failed (please report this)"
+-fi
+-AC_MSG_RESULT([$libc_version])
+-
+ dnl ---------------------------------------------------------
+ dnl These directories are used to search for include subdirs.
+ dnl ---------------------------------------------------------
+@@ -6122,7 +6074,6 @@
+ echo " WARNING: CC and XEMACS_CC mismatched; check CFLAGS carefully."
+ fi
+ fi
+-echo " libc version: $libc_version"
+ echo " Relocating allocator for buffers: $with_rel_alloc"
+ echo "
+ Package Search (a 'root' contains '{xemacs,mule,site}-packages'):"