summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/Manifest5
-rw-r--r--app-editors/xvile/metadata.xml1
-rw-r--r--app-editors/xvile/xvile-9.8y.ebuild (renamed from app-editors/xvile/xvile-9.8t-r1.ebuild)32
-rw-r--r--app-editors/xvile/xvile-9.8z.ebuild59
4 files changed, 88 insertions, 9 deletions
diff --git a/app-editors/xvile/Manifest b/app-editors/xvile/Manifest
index 2d066198a07c..a9cd6fd654ee 100644
--- a/app-editors/xvile/Manifest
+++ b/app-editors/xvile/Manifest
@@ -1 +1,4 @@
-DIST vile-9.8t.tgz 2352119 BLAKE2B fc1c75eba09e8be99945ba0d178fd150576d8108f906afb20dba265adaee9e5bea4869415d3ebceabf0b6b56c147add79e9c7e4fe34d7f4744930c3728e4a4a4 SHA512 4be4e37c7231395cae9236796073c2c3e428f1945283785a931c5d4cce94e0f970efa6634b0f9053679a00f4b4577704ea38ded2129e444b26ee9935a1c3d229
+DIST vile-9.8y.tgz 2477410 BLAKE2B 993f43a8e033e40d95c6d762daafebf328cae291380d448ec14b2a335569d5de7f628308433cb5abec15958bf1fc47c29f3f0ed49282f22cf7affd839c6ac2c6 SHA512 ce3c7178f6aecfd152e487d0053399739cf8880aa9c38283c9e4e7b95606fa2484f3cf9f7e797f538a47555be5257fbd34b112210e68a39d74f6b8ae7d968c32
+DIST vile-9.8y.tgz.asc 729 BLAKE2B 224cc75c025eb81b898990cb9f44a24e340664c658cead90f16d9103ed3bd3f15ce2c5dcf278c25f4a82069be2d39905f241c5d263b3170a731fb7e865cc45f7 SHA512 5475819801b6dcf3259811b5d3e29584a89baf574ca5685e61c6f98ba15c088ac6843bef66d2a9008b18fb4013fb40aa963ee48b15a786d6724f9ad7a599bd13
+DIST vile-9.8z.tgz 2491799 BLAKE2B a581d269931b2f14307a37e9ec9166cd66d6b48aea15405b6805d6ef2ff448342ff4027d10ef67ed9eace1083484ff282edd8f13341ed515a2f11efed9f8e74d SHA512 f5ff6f3d239f993d7b060e89650567e1c622cec1a024901e29d15cd9a588e8603097e12087d54e88beca91a3a7cd7328a541bac62889368da6636f143d6380ff
+DIST vile-9.8z.tgz.asc 729 BLAKE2B 62c9a5b34f3c1018df7e702dfc8e2bc24012aefb305abc1f21a58181a4ec89df6358d601ced10b41942c2bd63dc4e97f56987f90293deb4c8783dc0b98c38065 SHA512 0c7f5b64425f3f28833e54e072709687730e10fab7e231c1850335aa736ddeb5a6c800b66bab2ad6c79460d13987ee6803f9abb0606cd79682e2e1026b3ece25
diff --git a/app-editors/xvile/metadata.xml b/app-editors/xvile/metadata.xml
index 5156eb857fef..d110c3ebb42b 100644
--- a/app-editors/xvile/metadata.xml
+++ b/app-editors/xvile/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<changelog>https://invisible-island.net/vile/CHANGES.html</changelog>
+ <remote-id type="github">ThomasDickey/vile-snapshots</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-editors/xvile/xvile-9.8t-r1.ebuild b/app-editors/xvile/xvile-9.8y.ebuild
index e665c73095c6..70e771e477e2 100644
--- a/app-editors/xvile/xvile-9.8t-r1.ebuild
+++ b/app-editors/xvile/xvile-9.8y.ebuild
@@ -1,19 +1,25 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+# Bump with app-editors/vile
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
MY_P="${PN/x/}-${PV}"
DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
HOMEPAGE="https://invisible-island.net/vile/"
-SRC_URI="ftp://ftp.invisible-island.net/vile/current/${MY_P}.tgz"
+SRC_URI="https://invisible-island.net/archives/vile/current/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/vile/current/${MY_P}.tgz.asc )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ppc ~riscv sparc x86"
IUSE="perl"
-RDEPEND="perl? ( dev-lang/perl )
+RDEPEND="
~app-editors/vile-${PV}
virtual/libcrypt:=
>=x11-libs/libX11-1.0.0
@@ -21,16 +27,26 @@ RDEPEND="perl? ( dev-lang/perl )
>=x11-libs/libICE-1.0.0
>=x11-libs/libSM-1.0.0
>=x11-libs/libXaw-1.0.1
- >=x11-libs/libXpm-3.5.4.2"
-DEPEND="${RDEPEND}
+ >=x11-libs/libXpm-3.5.4.2
+ perl? ( dev-lang/perl:= )
+"
+DEPEND="
+ ${RDEPEND}
x11-base/xorg-proto
- sys-devel/flex"
+"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}"/${MY_P}
src_configure() {
econf \
+ --disable-stripping \
--with-ncurses \
+ --with-pkg-config \
--with-x \
$(use_with perl)
}
diff --git a/app-editors/xvile/xvile-9.8z.ebuild b/app-editors/xvile/xvile-9.8z.ebuild
new file mode 100644
index 000000000000..6cd5f2976846
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8z.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/vile
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/vile/current/${MY_P}.tgz.asc )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ~riscv sparc x86"
+IUSE="perl"
+
+RDEPEND="
+ ~app-editors/vile-${PV}
+ virtual/libcrypt:=
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ perl? ( dev-lang/perl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig
+ verify-sig? ( >=sec-keys/openpgp-keys-thomasdickey-20240114 )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}