summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/amx')
-rw-r--r--app-emacs/amx/Manifest1
-rw-r--r--app-emacs/amx/amx-3.4.ebuild25
-rw-r--r--app-emacs/amx/files/50amx-gentoo.el5
-rw-r--r--app-emacs/amx/metadata.xml14
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/amx/Manifest b/app-emacs/amx/Manifest
new file mode 100644
index 000000000000..53352a654391
--- /dev/null
+++ b/app-emacs/amx/Manifest
@@ -0,0 +1 @@
+DIST amx-3.4.tar.gz 33916 BLAKE2B b3b6f6d97e10dcb759bf38a812094de528aaeffd0b8fd0f1d055f67696889939a88622151123986bde42d4a1355a8a4d6cf95b286012bcb5245c1edc9b19a71c SHA512 146b8f6acbe4acca63391771fca73d22f5ce60872f4d18abc865d6cb07f4d12ea01fd59235e1e5987d33b169ea7792368b72e92f8c6409846121850efb75511f
diff --git a/app-emacs/amx/amx-3.4.ebuild b/app-emacs/amx/amx-3.4.ebuild
new file mode 100644
index 000000000000..fa23093eb4a8
--- /dev/null
+++ b/app-emacs/amx/amx-3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Alternative M-x interface for GNU Emacs"
+HOMEPAGE="https://github.com/DarwinAwardWinner/amx/"
+SRC_URI="https://github.com/DarwinAwardWinner/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+# TODO: When ido is packaged: || ( app-emacs/ido app-emacs/ivy )
+RDEPEND="
+ app-emacs/s
+ app-emacs/ivy
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.mkdn )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/amx/files/50amx-gentoo.el b/app-emacs/amx/files/50amx-gentoo.el
new file mode 100644
index 000000000000..12393aba5772
--- /dev/null
+++ b/app-emacs/amx/files/50amx-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'amx-mode "amx"
+ "Use ido/ivy completion for M-x." t)
+(autoload 'amx "amx"
+ "Read a command name and execute the command." t)
diff --git a/app-emacs/amx/metadata.xml b/app-emacs/amx/metadata.xml
new file mode 100644
index 000000000000..20f49bf16359
--- /dev/null
+++ b/app-emacs/amx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/DarwinAwardWinner/amx/issues/</bugs-to>
+ <remote-id type="github">DarwinAwardWinner/amx</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>