summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/anaphora')
-rw-r--r--app-emacs/anaphora/Manifest1
-rw-r--r--app-emacs/anaphora/anaphora-1.0.4.ebuild22
-rw-r--r--app-emacs/anaphora/metadata.xml19
3 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/anaphora/Manifest b/app-emacs/anaphora/Manifest
new file mode 100644
index 000000000000..0cd25f16c880
--- /dev/null
+++ b/app-emacs/anaphora/Manifest
@@ -0,0 +1 @@
+DIST anaphora-1.0.4.tar.gz 9215 BLAKE2B 634cbf68b63bf815755eace47441b40571f9a0a466f552d908358b110e12b75b8256efba915762c53f3280092b12483f6eec6257d78845bd4bef9537d1157f2e SHA512 1cfdb9f91c8fee4598dbc01701cf6cf84296cf18ae244f061c82a753f47f4904fccf8fbc0299e87408e17b4e41df65455f56be393d003c16cf8932f1e9f86d5e
diff --git a/app-emacs/anaphora/anaphora-1.0.4.ebuild b/app-emacs/anaphora/anaphora-1.0.4.ebuild
new file mode 100644
index 000000000000..7dc6bcc3fb98
--- /dev/null
+++ b/app-emacs/anaphora/anaphora-1.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Anaphoric expressions for Emacs Lisp, providing implicit temporary variables"
+HOMEPAGE="https://github.com/rolandwalker/anaphora/"
+SRC_URI="https://github.com/rolandwalker/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.markdown )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test-batch
+}
diff --git a/app-emacs/anaphora/metadata.xml b/app-emacs/anaphora/metadata.xml
new file mode 100644
index 000000000000..bc649256f86a
--- /dev/null
+++ b/app-emacs/anaphora/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/rolandwalker/anaphora/issues/</bugs-to>
+ <remote-id type="github">rolandwalker/anaphora</remote-id>
+ </upstream>
+ <longdescription>
+ Anaphoric expressions implicitly create one or more temporary variables
+ which can be referred to during the expression. This technique can improve
+ clarity in certain cases. It also enables recursion for anonymous
+ functions.
+ </longdescription>
+</pkgmetadata>