summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/autothemer/autothemer-9999.ebuild')
-rw-r--r--app-emacs/autothemer/autothemer-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/autothemer/autothemer-9999.ebuild b/app-emacs/autothemer/autothemer-9999.ebuild
new file mode 100644
index 000000000000..1dc1423ba26a
--- /dev/null
+++ b/app-emacs/autothemer/autothemer-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+inherit elisp
+
+DESCRIPTION="Conveniently define themes for GNU Emacs"
+HOMEPAGE="https://github.com/jasonm23/autothemer"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jasonm23/autothemer.git"
+else
+ # Recompressed from NonGNU ELPA.
+ SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+
+ ELISP_REMOVE="${PN}-pkg.el"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/dash-2.10.0
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+ function-reference.md
+)
+
+elisp-enable-tests ert "${S}"/tests -l tests/"${PN}"-tests.el