summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/burly/burly-0.2.ebuild')
-rw-r--r--app-emacs/burly/burly-0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/burly/burly-0.2.ebuild b/app-emacs/burly/burly-0.2.ebuild
new file mode 100644
index 000000000000..787e5f49350a
--- /dev/null
+++ b/app-emacs/burly/burly-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Save and restore frames and windows with their buffers in Emacs"
+HOMEPAGE="https://github.com/alphapapa/burly.el"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/${PN}.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}