summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/burly')
-rw-r--r--app-emacs/burly/Manifest2
-rw-r--r--app-emacs/burly/burly-0.2.ebuild39
-rw-r--r--app-emacs/burly/burly-0.3.ebuild39
-rw-r--r--app-emacs/burly/files/50burly-gentoo.el2
-rw-r--r--app-emacs/burly/metadata.xml21
5 files changed, 103 insertions, 0 deletions
diff --git a/app-emacs/burly/Manifest b/app-emacs/burly/Manifest
new file mode 100644
index 000000000000..1e60e67cd393
--- /dev/null
+++ b/app-emacs/burly/Manifest
@@ -0,0 +1,2 @@
+DIST burly-0.2.tar.gz 231242 BLAKE2B e50999727d654485c8265a163849f26867721f914c59b501ca8a4a42a1c12589adcd5d85b3d9ca5a383cf235962f7ca8dd8668abed1b3453b256100043875ebd SHA512 75dc26d1fae53a3ce238318e184396b2d67ce08f500c185d9fd526d6fb50c2ea3ba5a5d60789cd9b111f37336f66b1e014a19cda8bb387d6add1484cf6dd8548
+DIST burly-0.3.tar.gz 233444 BLAKE2B e33bb8c55edfdbd4ad2876b82e79f092a00ae44d4cbc39c106cf9bc7c49059ae802fcd4dbd6488044a05493bf18c985032e2595029a33cc45720c68c29001764 SHA512 3e79a786873f8a94001c8d57f74eba54c2679d006256ba7bf1447c89cb5c33759d7f01f3b58eba83b496d07905daeaf04d6828b2f6ca3899f6c1cb9fa017aa05
diff --git a/app-emacs/burly/burly-0.2.ebuild b/app-emacs/burly/burly-0.2.ebuild
new file mode 100644
index 000000000000..787e5f49350a
--- /dev/null
+++ b/app-emacs/burly/burly-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Save and restore frames and windows with their buffers in Emacs"
+HOMEPAGE="https://github.com/alphapapa/burly.el"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/${PN}.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}
diff --git a/app-emacs/burly/burly-0.3.ebuild b/app-emacs/burly/burly-0.3.ebuild
new file mode 100644
index 000000000000..787e5f49350a
--- /dev/null
+++ b/app-emacs/burly/burly-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Save and restore frames and windows with their buffers in Emacs"
+HOMEPAGE="https://github.com/alphapapa/burly.el"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/${PN}.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}
diff --git a/app-emacs/burly/files/50burly-gentoo.el b/app-emacs/burly/files/50burly-gentoo.el
new file mode 100644
index 000000000000..e19cf1e132b9
--- /dev/null
+++ b/app-emacs/burly/files/50burly-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "burly-autoloads" nil t)
diff --git a/app-emacs/burly/metadata.xml b/app-emacs/burly/metadata.xml
new file mode 100644
index 000000000000..94f0aac4f7a9
--- /dev/null
+++ b/app-emacs/burly/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This package provides tools to save and restore frame and window
+ configurations in Emacs, including buffers that may not be live anymore. In
+ this way, it’s like a lightweight "workspace" manager, allowing you to
+ easily restore one or more frames, including their windows, the windows'
+ layout, and their buffers.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/burly.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/burly.el</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>