summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/cape')
-rw-r--r--app-emacs/cape/Manifest2
-rw-r--r--app-emacs/cape/cape-1.4.ebuild40
-rw-r--r--app-emacs/cape/cape-1.5.ebuild40
-rw-r--r--app-emacs/cape/cape-9999.ebuild40
-rw-r--r--app-emacs/cape/files/50cape-gentoo.el3
-rw-r--r--app-emacs/cape/metadata.xml16
6 files changed, 141 insertions, 0 deletions
diff --git a/app-emacs/cape/Manifest b/app-emacs/cape/Manifest
new file mode 100644
index 000000000000..7c3a1148e4c4
--- /dev/null
+++ b/app-emacs/cape/Manifest
@@ -0,0 +1,2 @@
+DIST cape-1.4.tar.gz 40299 BLAKE2B c1075551b2d1ba9555b41993067a4c96b122a3dd7147cb5378bfc2f41ac20e67606b4d0805adc35fe13d9cf70cb5b83ec86ae88471d2af9d6ceb8849b447938a SHA512 9890ec51b1202a1644767bf57d4174f388d90246a9d2b97e3f2c13c5a07371be3003b11275e2ba0cb41f0898f9185774e91db141947999ca4e8e31bc0e3efd22
+DIST cape-1.5.tar.gz 41327 BLAKE2B 5bf499786483161e485764b64dfe70f8aaf21e176e72f9a755fe0d681d107e690b28bc0c7d841b62154616e1dc38bf475577e7357719ce4e82a1184ac849e198 SHA512 d47e9c8b78a51e93e6dbd6c41440021eb117cb5c865a27cebeaf25a00891b7d315593e542f416c2b47c38f768b3fa663361f31798523534d60168dd68f2714b3
diff --git a/app-emacs/cape/cape-1.4.ebuild b/app-emacs/cape/cape-1.4.ebuild
new file mode 100644
index 000000000000..99068b9ad304
--- /dev/null
+++ b/app-emacs/cape/cape-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.org README.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/cape/cape-1.5.ebuild b/app-emacs/cape/cape-1.5.ebuild
new file mode 100644
index 000000000000..99068b9ad304
--- /dev/null
+++ b/app-emacs/cape/cape-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.org README.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/cape/cape-9999.ebuild b/app-emacs/cape/cape-9999.ebuild
new file mode 100644
index 000000000000..42896ab1f608
--- /dev/null
+++ b/app-emacs/cape/cape-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion At Point Extensions"
+HOMEPAGE="https://github.com/minad/cape/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.org README.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/cape/files/50cape-gentoo.el b/app-emacs/cape/files/50cape-gentoo.el
new file mode 100644
index 000000000000..84d436d35cd5
--- /dev/null
+++ b/app-emacs/cape/files/50cape-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/cape site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/cape-autoloads.el" nil t)
diff --git a/app-emacs/cape/metadata.xml b/app-emacs/cape/metadata.xml
new file mode 100644
index 000000000000..3927de1c26bc
--- /dev/null
+++ b/app-emacs/cape/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">minad/cape</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>