summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/citar')
-rw-r--r--app-emacs/citar/Manifest1
-rw-r--r--app-emacs/citar/citar-1.4.0.ebuild43
-rw-r--r--app-emacs/citar/files/50citar-gentoo.el2
-rw-r--r--app-emacs/citar/metadata.xml23
4 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
new file mode 100644
index 000000000000..0c77fdc6b931
--- /dev/null
+++ b/app-emacs/citar/Manifest
@@ -0,0 +1 @@
+DIST citar-1.4.0.tar.gz 1604664 BLAKE2B 26ebe97a6701fa8c8d528ad0c6d750ea5acebda1fe6322c157fe62995140a9b3f16274888e51110a01dbd1681d7552637bc230d5d1e95270157bc524c037d7da SHA512 42ddb8eec21ad8c53b77b5ee235cd839fdb8d3a3efef8db28effd2bfc63d1d25c1031abb21df476e0243c99aaa619c2d1f29142f5569deb06281774c960924a9
diff --git a/app-emacs/citar/citar-1.4.0.ebuild b/app-emacs/citar/citar-1.4.0.ebuild
new file mode 100644
index 000000000000..f72de66e4d91
--- /dev/null
+++ b/app-emacs/citar/citar-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citar/files/50citar-gentoo.el b/app-emacs/citar/files/50citar-gentoo.el
new file mode 100644
index 000000000000..6243866c44c2
--- /dev/null
+++ b/app-emacs/citar/files/50citar-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "citar-autoloads" nil t)
diff --git a/app-emacs/citar/metadata.xml b/app-emacs/citar/metadata.xml
new file mode 100644
index 000000000000..2ba5ec6831b5
--- /dev/null
+++ b/app-emacs/citar/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs package to quickly find and act on bibliographic references, and edit
+ org, markdown, and latex academic documents. This package provides a
+ completing-read front-end to browse and act on BibTeX, BibLaTeX, and CSL
+ JSON bibliographic data, and LaTeX, markdown, and org-cite editing support.
+ When used with vertico, embark, and marginalia, it provides similar
+ functionality to helm-bibtex and ivy-bibtex: quick filtering and selecting
+ of bibliographic entries from the minibuffer, and the option to run
+ different commands against them.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacs-citar/citar/issues/</bugs-to>
+ <remote-id type="github">emacs-citar/citar</remote-id>
+ </upstream>
+</pkgmetadata>