summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/citeproc-el')
-rw-r--r--app-emacs/citeproc-el/Manifest1
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.4-r1.ebuild53
-rw-r--r--app-emacs/citeproc-el/metadata.xml27
3 files changed, 81 insertions, 0 deletions
diff --git a/app-emacs/citeproc-el/Manifest b/app-emacs/citeproc-el/Manifest
new file mode 100644
index 000000000000..acceaadd26a0
--- /dev/null
+++ b/app-emacs/citeproc-el/Manifest
@@ -0,0 +1 @@
+DIST citeproc-el-0.9.4.tar.gz 109594 BLAKE2B f13c1c93110666d897127c31da39eee392161fada18aa5cee940dfe4968b565d45a397536aa3d8c902625be6c3b27d4a19fca4aeab83233fb549c3f35169adcd SHA512 6772fea40203221e7016a5a0a5c2522b72889202f89eef4603dcbdb8c3c8c0050c5aabee8d56d5e56148e100fac33cd24489d3e03f2caa85964796b7d89ae019
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.4-r1.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..e5a1398ba1c3
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/andras-simonyi/${PN}.git"
+else
+ SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/compat
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el
diff --git a/app-emacs/citeproc-el/metadata.xml b/app-emacs/citeproc-el/metadata.xml
new file mode 100644
index 000000000000..33a57a1b947e
--- /dev/null
+++ b/app-emacs/citeproc-el/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ citeproc-el is an Emacs Lisp library for rendering citations and
+ bibliographies in styles described in the Citation Style Language (CSL), an
+ XML-based, open format to describe the formatting of bibliographic
+ references (see http://citationstyles.org/ for further information on CSL).
+ The library implements most of the CSL 1.0.2 specification, including such
+ features as citation disambiguation, cite collapsing and subsequent author
+ substitution, and passes more than 70% of the tests in the CSL Test Suite.
+ In addition to the standard CSL-JSON data format, citeproc-el has
+ rudimentary support for reading bibliographic data from BibTeX, biblatex
+ and org-bibtex bibliographies and can produce output in several formats
+ including HTML and org-mode markup (see Supported output formats for the
+ full list).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/andras-simonyi/citeproc-el/issues/</bugs-to>
+ <remote-id type="github">andras-simonyi/citeproc-el</remote-id>
+ </upstream>
+</pkgmetadata>