summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/dap-mode/dap-mode-0.7.ebuild')
-rw-r--r--app-emacs/dap-mode/dap-mode-0.7.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-emacs/dap-mode/dap-mode-0.7.ebuild b/app-emacs/dap-mode/dap-mode-0.7.ebuild
deleted file mode 100644
index 38928cefa99b..000000000000
--- a/app-emacs/dap-mode/dap-mode-0.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-NEED_EMACS=26.1
-
-inherit elisp
-
-DESCRIPTION="Debug Adapter Protocol mode"
-HOMEPAGE="https://github.com/emacs-lsp/dap-mode/"
-SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-emacs/bui
- app-emacs/dash
- app-emacs/f
- app-emacs/ht
- app-emacs/lsp-mode
- app-emacs/lsp-treemacs
- app-emacs/posframe
- app-emacs/s
-"
-BDEPEND="
- ${RDEPEND}
- test? ( app-emacs/ert-runner )
-"
-
-DOCS=( CHANGELOG.org README.org )
-PATCHES=( "${FILESDIR}"/${PN}-dap-ui-images-root-dir.patch )
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${SITEETC}/${PN}|" -i dap-ui.el || die
-}
-
-src_test() {
- ert-runner -L . -L test --reporter ert+duration || die
-}
-
-src_install() {
- elisp_src_install
-
- insinto ${SITEETC}/${PN}
- doins -r icons
-}