summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/diff-hl/diff-hl-1.9.2.ebuild')
-rw-r--r--app-emacs/diff-hl/diff-hl-1.9.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/diff-hl/diff-hl-1.9.2.ebuild b/app-emacs/diff-hl/diff-hl-1.9.2.ebuild
new file mode 100644
index 000000000000..bc3d56940cfb
--- /dev/null
+++ b/app-emacs/diff-hl/diff-hl-1.9.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highlight uncommitted changes, jump between and revert them selectively"
+HOMEPAGE="https://github.com/dgutov/diff-hl/"
+SRC_URI="https://github.com/dgutov/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+DOCS=( README.md screenshot{,-dired,-margin}.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ebegin "Creating a git repository for tests"
+ git init "${S}" --initial-branch="master" &&
+ git add "${S}" &&
+ git config --local user.email "test@test" &&
+ git config --local user.name "test" &&
+ git commit --message "test" --quiet
+ eend "${?}" || die
+
+ emake EMACS="${EMACS} ${EMACSFLAGS}" test
+}