summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/doxymacs/doxymacs-1.8.0-r3.ebuild')
-rw-r--r--app-emacs/doxymacs/doxymacs-1.8.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/doxymacs/doxymacs-1.8.0-r3.ebuild b/app-emacs/doxymacs/doxymacs-1.8.0-r3.ebuild
new file mode 100644
index 000000000000..7c861e34d038
--- /dev/null
+++ b/app-emacs/doxymacs/doxymacs-1.8.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp flag-o-matic
+
+DESCRIPTION="Doxygen editing minor mode"
+HOMEPAGE="http://doxymacs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND=">=dev-libs/libxml2-2.6.13"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ append-flags -Wno-error #260874
+ econf --with-lispdir="${SITELISP}/${PN}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}