summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/doxymacs/doxymacs-1.8.0-r5.ebuild')
-rw-r--r--app-emacs/doxymacs/doxymacs-1.8.0-r5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/doxymacs/doxymacs-1.8.0-r5.ebuild b/app-emacs/doxymacs/doxymacs-1.8.0-r5.ebuild
new file mode 100644
index 000000000000..ebdbf92cef6f
--- /dev/null
+++ b/app-emacs/doxymacs/doxymacs-1.8.0-r5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Doxygen editing minor mode"
+HOMEPAGE="http://doxymacs.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=dev-libs/libxml2-2.6.13"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-gcc7.patch
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-lispdir="${SITELISP}/${PN}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ einstalldocs
+}