summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ecukes/ecukes-0.6.18-r1.ebuild')
-rw-r--r--app-emacs/ecukes/ecukes-0.6.18-r1.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild b/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
index 1e8bbe61c27d..153017cef0f8 100644
--- a/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
+++ b/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/ecukes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -34,10 +34,17 @@ BDEPEND="
DOCS=( README.markdown )
PATCHES=( "${FILESDIR}"/${PN}-bin-launcher-fix.patch )
-# Remove pkg file and failing tests
-ELISP_REMOVE="${PN}-pkg.el test/${PN}-parse-line-test.el"
+# Remove pkg file and failing tests.
+ELISP_REMOVE="
+ ${PN}-pkg.el
+ test/${PN}-parse-line-test.el
+ test/${PN}-run-test.el
+ test/${PN}-steps-test.el
+"
SITEFILE="50${PN}-gentoo.el"
+elisp-enable-tests ert-runner test
+
src_prepare() {
elisp_src_prepare
@@ -49,13 +56,10 @@ src_compile() {
elisp-compile reporters/*.el
}
-src_test() {
- ert-runner --reporter ert+duration --script || die
-}
-
src_install() {
elisp_src_install
elisp-install ${PN}/reporters reporters/*.el{,c}
- dobin bin/${PN}
+ exeinto /usr/bin
+ doexe bin/${PN}
}