summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/eldoc-box/eldoc-box-1.11.1.ebuild')
-rw-r--r--app-emacs/eldoc-box/eldoc-box-1.11.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/eldoc-box/eldoc-box-1.11.1.ebuild b/app-emacs/eldoc-box/eldoc-box-1.11.1.ebuild
new file mode 100644
index 000000000000..e466b68c6ef4
--- /dev/null
+++ b/app-emacs/eldoc-box/eldoc-box-1.11.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Child frame doc for Eglot and anything that uses ElDoc"
+HOMEPAGE="https://github.com/casouri/eldoc-box"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/casouri/${PN}.git"
+else
+ SRC_URI="https://github.com/casouri/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}