summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/elpher/elpher-3.5.1.ebuild')
-rw-r--r--app-emacs/elpher/elpher-3.5.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/elpher/elpher-3.5.1.ebuild b/app-emacs/elpher/elpher-3.5.1.ebuild
new file mode 100644
index 000000000000..7f6e304ce54d
--- /dev/null
+++ b/app-emacs/elpher/elpher-3.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Practical and friendly Gopher and Gemini client for GNU Emacs"
+HOMEPAGE="https://thelambdalab.xyz/elpher/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://thelambdalab.xyz/${PN}.git"
+else
+ if [[ "${PV}" == 3.5.1 ]] ; then
+ COMMIT=3f53ed5
+
+ SRC_URI="https://thelambdalab.xyz/gitweb/index.cgi?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ else
+ die "could not generate SRC_URI"
+ fi
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+ELISP_REMOVE="elpher-pkg.el"
+
+DOCS=( ISSUES.org README )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"