summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20201116.ebuild')
-rw-r--r--app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20201116.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20201116.ebuild b/app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20201116.ebuild
new file mode 100644
index 000000000000..42b072a67dc3
--- /dev/null
+++ b/app-emacs/flycheck-clang-tidy/flycheck-clang-tidy-0.3.0_p20201116.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Flycheck syntax checker using clang-tidy"
+HOMEPAGE="https://github.com/ch1bo/flycheck-clang-tidy"
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="f9ae7306bd6ca08b689b36c1e8f6f6b91d61db5f"
+ SRC_URI="https://github.com/ch1bo/flycheck-clang-tidy/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/ch1bo/flycheck-clang-tidy/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ >=app-emacs/flycheck-0.30
+"
+RDEPEND="
+ ${BDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"