summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/flycheck-package/flycheck-package-0.14.ebuild')
-rw-r--r--app-emacs/flycheck-package/flycheck-package-0.14.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/flycheck-package/flycheck-package-0.14.ebuild b/app-emacs/flycheck-package/flycheck-package-0.14.ebuild
new file mode 100644
index 000000000000..fa101840c718
--- /dev/null
+++ b/app-emacs/flycheck-package/flycheck-package-0.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Flycheck checker for Emacs Lisp package metadata"
+HOMEPAGE="https://github.com/purcell/flycheck-package/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="amd64"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/flycheck
+ app-emacs/package-lint
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"