summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ghub')
-rw-r--r--app-emacs/ghub/Manifest3
-rw-r--r--app-emacs/ghub/ghub-3.5.4.ebuild25
-rw-r--r--app-emacs/ghub/ghub-3.5.6.ebuild31
-rw-r--r--app-emacs/ghub/ghub-3.6.0.ebuild36
4 files changed, 37 insertions, 58 deletions
diff --git a/app-emacs/ghub/Manifest b/app-emacs/ghub/Manifest
index 2e322c66bf73..9c4177794811 100644
--- a/app-emacs/ghub/Manifest
+++ b/app-emacs/ghub/Manifest
@@ -1,2 +1 @@
-DIST ghub-3.5.4.tar.gz 58088 BLAKE2B 5ee6fe56455e8f12e7be8c1ae705a426677fab0b9a5da8f42c4b331bdd635120a2f5475055c9e98c8df01b259f76aa2dd4cad6e8b4562481d261bb7802b826f6 SHA512 df8ba56195ae3773c0c8c8a8f555e562b04de59ce3fb1c17c24ca3b10418299555326f0a9360eb47725310890e31f73221eece3ca1ff83e47d52941e224fc562
-DIST ghub-3.5.6.tar.gz 59474 BLAKE2B c27610f24526a40b5f36d2f5154c0eeb9f86e9da676baa82b2866a0bb58de8a78736d56a5d6454666b539774abbf5dfcd260880aa07499616f44a3e2c8315999 SHA512 6c6724978f0809a4977cc7965de4c33eaf29537c13507aabffecae4a7d2b3710074179d819aee1a54fce8f12e20db46b18466c3f1012d3b9c41eae3c2fade58a
+DIST ghub-3.6.0.tar.gz 62572 BLAKE2B 5693177be9ac22d18b7b6f5cdc230eea4340a5bfd007fa4b18f3503fe796fd8b104753be51c8579de6e693cfc620c4524dae195627af4c542bd2fe94aad1d0dd SHA512 e54752f70c462ce4fed3a1fc3ca60f22107e2acaefb06ebf42d35c6b65f9091bba07ff72436310782d9be7fbf35aef473dbbe39ef7a4ac3de1ebd82a417c6b0a
diff --git a/app-emacs/ghub/ghub-3.5.4.ebuild b/app-emacs/ghub/ghub-3.5.4.ebuild
deleted file mode 100644
index ff3df1514bdf..000000000000
--- a/app-emacs/ghub/ghub-3.5.4.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-NEED_EMACS=25
-
-inherit elisp
-
-DESCRIPTION="Minuscule client library for the Git forge APIs"
-HOMEPAGE="https://magit.vc/manual/ghub"
-SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-SITEFILE="50${PN}-gentoo.el"
-ELISP_TEXINFO="*.texi"
-DOCS="README.md"
-
-RDEPEND="
- >=app-emacs/treepy-0.1.1
-"
-BDEPEND="${RDEPEND}
- sys-apps/texinfo"
diff --git a/app-emacs/ghub/ghub-3.5.6.ebuild b/app-emacs/ghub/ghub-3.5.6.ebuild
deleted file mode 100644
index 64e656791e15..000000000000
--- a/app-emacs/ghub/ghub-3.5.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-NEED_EMACS=25
-
-inherit elisp
-
-DESCRIPTION="Minuscule client library for the Git forge APIs"
-HOMEPAGE="https://magit.vc/manual/ghub"
-SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-SITEFILE="50${PN}-gentoo.el"
-ELISP_TEXINFO="docs/ghub.texi"
-DOCS="README.md"
-
-RDEPEND="
- >=app-emacs/treepy-0.1.1
-"
-BDEPEND="${RDEPEND}
- sys-apps/texinfo"
-
-src_prepare() {
- default
- mv lisp/*.el . || die
- rm ghub-pkg.el || die
-}
diff --git a/app-emacs/ghub/ghub-3.6.0.ebuild b/app-emacs/ghub/ghub-3.6.0.ebuild
new file mode 100644
index 000000000000..aa30f4aca220
--- /dev/null
+++ b/app-emacs/ghub/ghub-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub/
+ https://github.com/magit/ghub/"
+SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.org )
+ELISP_TEXINFO="docs/ghub.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+ >=app-emacs/treepy-0.1.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ default
+
+ mv lisp/*.el . || die
+ rm ghub-pkg.el || die
+}